1. jgoodm's Avatar
    Hi All,

    I Pwn'd my phone, everything is unlocked and working when using a T-Mobile or ATT Sim. I tried using a global Sim (Called a "Passport Sim Card" from Telestial dot com) which is used for taking to Europe and uses a call back/ring back service. (On a normal phone with this Sim, when you make a call, you dial the number you want to call and press send. The call is made and instantly hangs up. A second or two later the phone rings you back and when you answer the the phone it is ringing through to the number you wanted to call.)

    When I use this Sim, the phone registers on ATT or T-Mobile's network (as it should). I then dial a number and the phone seems to initiate the ring back, but when I answer the call the phone does nothing. It appears to be in a call but the timer stays at 0:00 and the phone partially freezes. If I hang up, the phone tries to indicate that the initial outbound call fails and wants to call out again.

    Has anyone had this problem? Does anyone have any suggestions for how to fix this?

    2008-04-07 09:14 PM
  2. ccrews's Avatar
    Same problem here. Did you ever find a solution? My passport SIM worked in prior versions of iPhone software. But since 1.1.4 I have had the same issues. Is there any other "world" SIM's that I should consider?
    2008-05-20 08:52 PM
  3. Rangers4me's Avatar
    Anyone get it to work? I notice that there is a "Callback" option under SIM Applications.
    2008-06-18 05:15 AM
  4. ccrews's Avatar
    Ended up calling telestial and they told me the sim was no longeractive and that i needed a new one. They sent a new one at no charge and it is working fine here in england at the moment and worked well in Paris and Rome as well.

    Must use the *126*1234567890# dialing and then the callback works.
    2008-06-20 07:49 PM
  5. jgoodm's Avatar
    Thanks for the reply.

    What is *126*?
    2008-06-20 08:35 PM