1. yeahitzdat's Avatar
    I unlocked my iPhone with anysim on 1.02 will it work with any sim card from Europe? and when i put a T-Mobile sim card in it it shows a red dot on the phone icon is there anyway to fix that?
    2007-10-19 02:27 AM
  2. noall666's Avatar
    Hey , just want to see if you went over to europe nd got your unlocked phone to work over there, I hve a 1.0.2 unlocked usa phone and i got my ornge to work while in the usa, but when i got over here to the uk, it doesnt work, the ornge sim that is, the att one works fine.... any help..
    thx
    later
    2007-12-18 02:17 PM
  3. Groom's Avatar
    > yeahitzdat

    The red dot appears because the special voicemail features will work only with AT&T.

    Concerning your other question the answer is: I don't know but it didn't work for me.

    Actually I am having the same problem as noal666. I unlocked with anySim and tested with a T-Mobile card in the states and everything worked great. I get to London and use a Vodafone card and I get the error: "Incorrect SIM. Please connect to iTunes".

    Then I actually try running anySim again (had to try something) and it told that it couldn't unlock the phone.

    Any thoughts anyone?
    2007-12-18 09:32 PM
  4. noall666's Avatar
    I was to scared to try anysim again, but at least i know that didnt work for you.... I going to stores tomorow and trying all different sims from different manufactures , we'll c what happans, then i think we may have to up grade to 1.1.1 unless you have that version then i gott come up with another plan...????
    anyone else, HELP , Please....
    2007-12-19 01:07 PM
  5. Groom's Avatar
    it was 1.1.1 out of the box phone and it was already active when I unlocked it which might be a problem from what I saw in another post.

    Let me know what happens with other operators because I will be going around Europe for the next few weeks and I am hoping I will be able to use other SIMs.
    2007-12-20 11:14 AM
  6. noall666's Avatar
    OK, I have been out and about and have tried a few things, to no avail....
    tried all these sims, vodafone, o2, orange, t mobile.... all do not work in my unlocked phone. these sims are all UK sims. I unlocked it in the usa. also , I tried the anysim again and it tells me its already been unlocked, wait heres what it says exactly....
    "the firmware on this iphone is already patched. anysim will now quit. please turn off your phone and turn it on again after anysim quits"
    also. I have noticed something wierd. I have 1.0.2 software but have modem firmware 4 01 13 g. how is this possible......
    very strange...so maybe thats it, my next step is to say **** it and upgrade to 1.1.1 and try that. wish me luck. i keep you all posted..... unless someone else has a better idea in the next hour or so....

    OK, I fuckin got it. I downgraded my baseband and did NOT have to upgrade to 1.1.1.......
    So I just downgraded baseband in the apps area. restarted, put the orange sim in, used anysim 1.0.2 and it unlocked it...... NOW all the sims work, o2(UK) orange(UK) and my usa att sim...must have somehow got ****** in my unlocking the first time that gave it the wrong firmware..... so anyway..... it works, yippie..... need help just ask.... i know this thing pretty good for not having a clue about unix and teminal ****.....thx guys out there on the dev team.... u guys rock, lets keep fuckin over the man.....
    Last edited by noall666; 2007-12-21 at 01:34 PM. Reason: Automerged Doublepost
    2007-12-21 01:34 PM
  7. Groom's Avatar
    Ok so I finally got this working.

    I don't know if the problem was caused because I unlocked an already activated phone but the solution was given by jacobzking in another thread in this forum.

    I though I'd quote his original post here just in case you or other people haven't found it.

    sounds to me like the phone was either activated by Apple (if they replaced a phone for you) or the phone was activated with an AT&T SIM card. Easy solution is just SFTP to the phone go to usr/libexec and replace the lockdown file with the patched 1.1.1 If you need it, email me [email protected] takes 5 seconds to fix
    I have tried the Vodafone SIM and a SIM by a Greek operator and both worked like a charm.
    2007-12-24 10:31 AM
LINK TO POST COPIED TO CLIPBOARD