1. darenlim's Avatar
    Hello guys, I am a big fan of this website and love all the cool tips and stuff. As i was reading through one of the posts, it mentioned about resetting network settings to enable bluetooth to work with my headset. I did just that and now my WIFI cant detect any network at all. I have tried going to 4 different places to connect to their networks and yet wifi cannot locate any networks. I am in Singapore and have a 1.0.2 version which was unlocked by my vendor in Singapore.

    I read through every possible thread there is on this problem here and another website but still found no solutions. Is there anyone that could help me out here. I am desperately in need as I dpend alot on Wifi to get my work done when I travel overseas (Excluding USA, CANADA & Europe). Definitely would greatly appreciate it.
    2007-10-19 12:50 PM
  2. khanay's Avatar
    i have the same problem...i have many unsecured networks at my job and my iphone cant detect anyone of them...now my friend's iphone works fine in that specific location...i guess i have a bad hardware here..have to take it an apple store if there is no quick solution...
    i have tried restoring the phone and also resetting the network setting and even tried turning on the airport for 20 secs but none of it seems to work.
    cant believe it i got a malfunctioned hardware outta the box
    2007-11-01 10:46 AM
  3. mckinley's Avatar

    I have the same problem too!
    I tried everything!
    Upgrade 1.1.1 wifi still not works!
    Downgrade 1.0.2 still nothing.
    Revirginizing and everything.
    I tried this:
    1. You will need to install MobileTerminal from iBrickr.
    2. All the files you need to downgrade are here http:// rapid share .com/files/65281362/downgrade-baseband_Folder.zip.html
    3. Use iBrickr to upload the files bbupdater, ICE03.14.08_G.eep, ICE03.14.08_G.fls, ieraser, and secpack to /usr/bin/
    4. Fire up Terminal on your phone, cd to /usr/bin and issue this command to stop the modem service:
    launchctl unload /System/Library/LaunchDaemons/com.apple.CommCenter.plist
    5. Type this in:
    chmod +x bbupdater
    chmod +x ieraser
    6. Run ieraser
    7. After that you can run bbupdater like this:
    bbupdater -f *.fls -e *.eep
    8. Run bbupdater -v
    ...and it should tell you that you have version 3.14
    9. Restart your phone.
    This will update your BB software and it should bring back bluetooth and wi-fi. Just in case go to Setting-General-Reset and hit Reset All Settings
    (My bluetooth and wi-fi did NOT work until I did Reset All Settings, even though the BB upgrade went OK)"
    (Via: http://hackint0sh.org/forum/showthread.php?t=13315)
    But still nothing!

    So i have no wifi network. But i have 3 perfectly working wifi hotspot.
    Last edited by mckinley; 2007-11-02 at 05:26 AM.
    2007-11-02 03:16 AM