1. kyoru's Avatar
    So I bought a brand new iphone 1.11 and thought it would be pretty easy to unlock myself. Boy was I wrong. Anyways I decided to write my experience here for future unlockers everywhere.

    My first attempt at unlocking the phone I used the *#307# dial method to access Safari to go to jailbreakme.com for the unlock. This went fine until i was halfway through anysim unlocking and i pushed the home key by accident. this basically messed up my phone to the point where I could not use wi-fi. I thought to my self no biggie just restore it. Wrong again I was unable to restore the phone because of the annoying 1011 error.

    Fixing the 1011 Error
    I tried everything to fix this, uninstall, reinstall, clear the cache, temp files and old itunes files. None of them worked. The only way I could get past the annoying error was to fix it using iBrickr, which some how saved it. I then restored the phone back to 1.02 firmware.

    After that my phone needed to be activated, so I used PACAY which did its job. I thought to myself okay home stretch. I then realized that my signal strength was still nothing and my wifi option was grayed out. So I followed the baseband and corrupt seczone guide (http://modmyi.com/forums/showthread.php?t=10461). This didn't seem to do anything so I went ahead and installed anySim via iBrickr and unlocked the phone. Vola the phone had signal strength now, but my wifi was still gone. I followed a lead about restarting the phone during the baseband downgrade, and it worked!

    Fixing grayed Out Wifi
    Okay to fix the grayed out wifi option, I used Mobile Terminal.
    After you unload the service,
    Code:
    launchctl unload -w /System/Library/LaunchDaemons/com.apple.CommCenter.plist
    simply turn off your phone, then in Mobile Terminal

    Code:
    launchctl load -w /System/Library/LaunchDaemons/com.apple.CommCenter.plist
    This can be done even after the baseband downgrade because all your doing and turning the service off and on.

    Hope this saves headaches for a few of you.
    2007-11-03 09:59 AM
  2. ratfuck's Avatar
    This is an amazing story. I am still trying to jailbreak my "no wifi" 1.0.2 downgraded iphone.
    I too got screwed while trying to use the "http://jailbreakme.com/" site.
    I just killed my wifi, and cannot get my phone unlocked without wifi.

    I followed the steps you mentioned, but the ibrickr "free my phone" option does not complete. Is there another way to jailbreak?

    thanks
    2007-11-06 06:18 AM
LINK TO POST COPIED TO CLIPBOARD