1. casadk's Avatar
    I followed the hacktheiphone guide to upgrade from a 1.0.2 unlocked phone to 1.1.1 (i didnt notice that it would only work with a alreadi virginized phone). Oh well, that didnt work. Then i virginized, got back to 1.0.2. upgraded to 1.1.1 (using independence) and activated and jailbreaked. Everything worked, except the actual phone part. I used AnySim 1.1 to unlock and it said SUCCESS. I then rebooted and tried to enter my sim pass, no luck. The phone keeps saying incorrect sim, this iphone must be used with an approved SIM”. I also tried to activate and deactivate in independece again, but no luck. this is really annoying, because everything else works. Itunes store, youtube, wifi - everything. Exept the most important part, the phone. This is really killing me, because ive also tried to get it to work on a basic 1.0.2 again, but the same issue.

    Does anyone know a solution to this? I thought i might not virginize it decently, but everything match in this guide (i compared the firmwares etc).

    This guide i used (after i restored to 1.0.2) is http://modmyi.com/wiki/index.php...nd_OS_X_iPhone

    My IMEI is the same as on the box still.

    Please help .. :-) I know some of you inhere are geniouses regarding the iphone :-)


    2007-11-05 11:00 AM
  2. yees-no's Avatar
    I have the same problem >_<
    every thing is working fine exept the phone. tried anysim 1.1 and i get the same msg saying incorrect sim.

    I hope some one can help us
    2007-11-05 12:27 PM
  3. casadk's Avatar
    yees-no.. i just got word that we should try to remove the simlock on the simcard (in another phone) and then put it back in the iphone again, since there could be a problem with the iphone and simlock.. im at work right now, so cant really try it out, but maybe u can... i really hope something will fix it, and i know it will be fixed at some time.. i just miss my phone so much
    2007-11-05 12:44 PM
  4. yees-no's Avatar
    just tried to install onesim and then used anysim it says succes but nothing happend =-/
    2007-11-05 01:01 PM
  5. casadk's Avatar
    yees-no, try to put your sim in another phone, deactivate that its using the pinnumber, then put it in iphone again and try. i havent tried it, since im not home, but its worth a shot.
    2007-11-05 01:45 PM
  6. yees-no's Avatar
    I did it still not working
    2007-11-05 03:16 PM
  7. ReVan's Avatar
    You need to follow Phase 2.5 from my guide
    2007-11-05 04:33 PM
  8. yees-no's Avatar
    I think anysim is not working coz the IMEI number is wrong. The real number is behind the Iphone.

    But if u go to settings - General - About -IMEI u will see another number.

    To fix this we need to restore it to factory state.
    I found this app under unlocking Tools but its not working with 1.1.1 .

    Hope thats we will find a solution soon.
    2007-11-06 12:50 PM
  9. pauschpage's Avatar
    I also have the same Problem.
    IMEI is the same as on the box.

    Anyone solved this Problem already?

    2007-11-06 03:01 PM
  10. jwm0z's Avatar
    Find the (Click here) activate.bat file and associated files and try that
    2007-11-06 03:13 PM
  11. alth3lab's Avatar
    i have the same problem!!!!!!!!!!!!
    Anyone solved this Problem??????
    2007-11-07 05:45 AM
  12. helpingjames's Avatar
    Did Any One Get This Thing To Work Yet
    2007-11-09 04:01 AM
  13. yees-no's Avatar
    nothing yet m8
    2007-11-09 11:31 PM
  14. wichogt's Avatar
    i have the same problem with anySIM1.1, but i am executing anysim with no AT&T sim, because i don't have one.
    2007-11-10 12:20 AM
  15. wichogt's Avatar
    ok, i have my iphone working 100&#37; again but with 1.0.2 firmware... i downgrade it again and and virginizing with 03.14.06_G with the http://i.unlock.no source install on the iphone

    ok i solved it for 1.1.1 firmware.... once you virginiz it whit and unlock it, just upgrade it ti 1.1.1 and unlock it with anySIM
    Last edited by wichogt; 2007-11-11 at 05:53 PM. Reason: Automerged Doublepost
    2007-11-11 05:53 PM
  16. mohak1's Avatar
    after virginizing the baseband to 3.x and firmware 1.0.2

    u will need the anysim 1.0.1 or 1.0.2 to unlock the phone...

    anysim 1.1 does not work on firmware 1.0.2 or lower...

    u can get the older version of anysim from ibrickr via application browsing in it...
    2007-11-11 08:35 PM
  17. saayd's Avatar
    And me too ,

    Same problem : Incorrect Sim & wrong IME Number


    2007-12-23 10:45 PM
  18. DeL_R's Avatar
    i have a otb 1.1.2 iphone have the corrtect imei number but have the invalid sim message cany any help me to get rid of this
    2007-12-23 11:05 PM
  19. reddevilseye's Avatar
    if imie is correct just restore 1.1.1 and jailbreak then anysim dont install nothing before anysim or it won't work I got this longtime ago and this was the solution for it
    if ur imie is not ok u need to fix it on 1.0.2 with the available wiki instructions
    I hop that will help

    1.1.2 OTB unlockable yet
    Last edited by reddevilseye; 2007-12-23 at 11:30 PM. Reason: Automerged Doublepost
    2007-12-23 11:30 PM
  20. yowiphone's Avatar
    Yeah its your IMEI problem.
    Iphone Love... I dreamed of a iphone before it was out..
    2007-12-23 11:44 PM
24 12