1. dubsub's Avatar
    Hi there,

    I have an iPhone with a non-official SIM card in it. I recently purchased the iPhone developer program (certs, provisioning, etc.), and I'm running into trouble to "activate" my iPhone during the restoration process of beta 5 (5a274d). I have the certs installed and the provision profile installed too. I was on 1.1.4 (but I also tried with 2.0 beta 3 with PwnageTool) and directly proceeded into the steps describle on Apple's iPhone developer documentation (Restore with XCode, activate with iTunes).

    Now my question is simple, I get the "purple screen of death" and iTunes pops-up with this error message when activating the iPhone: "The SIM card inserted in this iPhone does not appear to be supported". I am a legit developer but not having a "valid" SIM card to activate. I heard people saying you don't need it, and that the system ID (40 bytes hexadecimal) should be OK to activate. This is not the case. Is it possible to activate the phone without a legit SIM card ?

    BTW, while restoring I see the baseband being flashed, so the activation just "goes away" I think... Maybe putting the offical baseband and activate it with Ziphone would help ?

    I would really appreciate some help/feedback of some other developers in my situation.

    Thanks in advance !
    2008-05-09 03:43 AM
  2. k0nstantin's Avatar
    Hi. I'm glad to at least hear from someone having the exact same problem I have. I have registered and payed for the iPhone Developer program. And I have been accepted!

    I bought a clean iPhone, installed the latest Xcode iPhone SDK and downloaded the latest iPhone OS 2.0 (beta 5).

    Registered the iPhone and installed according to instructions.

    All this has gotten me is a Pink Screen Of Death. I cant even RESTORE back to 1.1.4, much less do any development on the phone.

    I thought just as you, that I would be able to develop using an iPhone without a SIM card. I understood that I would not be able to use the iPhone for making calls, just for developing. But no.

    I have been looking all over the Internet for a solution. And I cant find any info at all about this, not even a comment.

    But beta 5 is rather fresh ... so there might come a solution. But it hurts, as I am a completely honest-legit-apple-registered-developer.

    The solution?

    Well ...eeh ... as there are no iPhone carriers in my country (yet) I guess I'm supposed to develop on an iPod Touch. Guess I have to throw my new iPhone in the bin and go out and buy a new Touch. Sad, stupid and expensive!

    But I probably will do it anyway ...

    Please let me know if you find a (better) solution to this!
    2008-05-11 12:55 PM
  3. Apple iPie's Avatar
    This question may sound kinda stupid,but did you try DFU restore to 1.1.4?
    2008-05-11 03:10 PM
  4. k0nstantin's Avatar
    Not a stupid question at all.

    But, yes I have ... It seems to work at first. The iPhone goes into RESTORE mode and I can [alt] + click the restore button and select the 1.1.4 ispw. iTunes starts to do the "downgrade" ... but after about 2 minutes I just get an error (a "1604"). The only way out is to restore back to 2.0 beta 5 – which renders a useless bricked iPhone (to me at least).
    Last edited by k0nstantin; 2008-05-17 at 09:29 PM. Reason: 1604 error confirmed
    2008-05-11 03:56 PM
  5. prince_johri's Avatar
    hmmm...I will suggest to use Ziphone to enter the DFU mode and then goto itunes and press shift + restore (Not Alt + restore!!)...and then try the 1.1.3 version..you will get some error in the end..just ignore it and again use the ziphone to come to Normal mode..hope this will help
    2008-05-14 01:10 AM
  6. k0nstantin's Avatar
    @prince_johri:
    Ok, I will give that a try. I doubt it will work though ... as the beta 5 installs a completely new BL. I will let you know how it goes ...
    2008-05-17 08:12 PM
  7. Apple iPie's Avatar
    You mean,BETA 5 upgrades your BOOTLOADER??????,NOT BASEBAND?
    BL=bootloader though...
    2008-05-17 08:54 PM
  8. k0nstantin's Avatar
    Yes, sorry. You are right. I mean BB.

    @prince_johri:
    What do you mean with SHIFT + Restore...? When using SHIFT + Restore, iTunes just want to download and restore to the latest official firmware. But with ALT + Restore I can choose any firmware I want (if I have downloaded the ipsw).. or did I miss something?

    I got the 1604 error (again) after trying to Restore to 1.1.3... I will ignore that and I'm now going back to Ziphone ...

    Process Log:
    Checking ZiPhone integrity...
    i386
    Searching for iPhone...

    Then nothing. Ok, tried that. Did NOT work...
    Last edited by k0nstantin; 2008-05-17 at 09:27 PM. Reason: Automerged Doublepost
    2008-05-17 09:27 PM
  9. prince_johri's Avatar
    dude for me its shift + restore which allows me to select the firmware...i m working on windows XP...what abut u??
    2008-05-17 10:45 PM
  10. mbrooksr's Avatar
    2008-05-17 10:50 PM
  11. k0nstantin's Avatar
    @prince_johri:
    That's it! I'm in Mac...
    2008-05-17 10:58 PM
  12. prince_johri's Avatar
    dude then i will suggest you to follow what "mbrooksr" has suggested...right now i am just too busy with my exams so cant help much otherwise i would have looked this thing for you..sorrryyy
    2008-05-18 12:06 AM
  13. k0nstantin's Avatar
    Yes .. doing that right now ... and it seems to go rather well. Thanks mbrooksr!
    2008-05-18 12:13 AM
  14. prince_johri's Avatar
    sorry i cudnt help much!!
    Last edited by prince_johri; 2008-05-18 at 12:25 AM.
    2008-05-18 12:21 AM
LINK TO POST COPIED TO CLIPBOARD