1. vamonto's Avatar
    I understand it's not possible to unlock an OTB 1.1.2 but I just wanted a clarification on why:

    With regards to jailbreaking/unlocking there appears to be 3 relevant components:

    1) Firmware
    2) Baseband
    3) Bootloader

    Currently, there are methods to revert both Firmware and Baseband but not the Bootloader

    Although anySIM unlocks the phone by modifying the Baseband, we cannot unlock OTB 1.1.2 iPhones b/c anySIM can not run on the new Bootloader?

    Any clarification is appreciated... it feels good to understand these things

    Thanks,
    2007-12-08 03:28 AM
  2. annaj's Avatar
    i don't know if it is that anysim cannot RUN on the new bootloader,
    or if it cannot modify the bootloader,

    but either way, you are correct that it is the bootloader that is the problem,
    from my understanding (though I'm not a programmer, or hacker in any way)
    2007-12-08 06:55 AM
  3. iphonesolutionz's Avatar
    The bootloader does not allow you to insert any other SIM other than ATT. It checks to see is the SIM you have inserted is in fact an ATT card.
    2007-12-08 07:25 AM
LINK TO POST COPIED TO CLIPBOARD