1. HECTOR1965's Avatar
    Hi Can anyone help???
    might be me being a bit thick but done a full restore on my iphone to 1.1.4 (4a102) through itunes 7.6. I then run ziphone and click on the do it all button and it runs through everything says its unlocked all finished everything looks fine and seems to be fine. installed bbinfo to see all settings 04.04.05_G is the modem firmware. bootloader version 3.9_m3s2.
    so it all look and works well only problem being it will not take any carrier says no service all the time.
    can someone please tell me if i am doing something wrong or if i need to do something different.
    all help would be much appreciated.
    thanks
    2008-06-24 07:49 PM
  2. hiflyer's Avatar
    Try doing a DFU Restore back to stock 1.1.4 and setup as NEW.

    1. Connect to your computer, hold the power and home buttons down (the iphone will power off after about 10 seconds, but keep holding both buttons down)
    2. As soon as the iPhone powers off, (black screen) release the power button (but keep holding the home button down). (If you see the apple logo or connect to itunes logo you are not in DFU mode so try it again)
    3. After about 20 seconds or so, Itunes should see your iphone. It is now safe to release the home button, and your iPhone is in DFU mode.
    Now iTunes should ask you to restore its firmware.

    Restore to 1.1.4 and jailbreak with iliberty+
    2008-06-24 08:27 PM
  3. HECTOR1965's Avatar
    ok done that now and everything seems fine. shows the different carriers in top left hand corner when i put different sims in, but does not let me make calls just says failed.everything else works great and the phone does look like it will accept different carriers. anyone any ideas???
    Thanks
    2008-06-24 11:13 PM
  4. Poseidon79's Avatar
    Where do you live and what carriers are you trying to use it on? Do these SIM cards make and receive calls in other phones successfully?
    2008-06-24 11:17 PM
  5. HECTOR1965's Avatar
    ok live in wigan uk, have another iphone unlocked 1.1.2 and the other sims work fine in that. vodaphone and virgin mobile. really weird
    thanks
    2008-06-24 11:26 PM
  6. Poseidon79's Avatar
    Just to verify... you did a DFU RESTORE... then did the jailbreak/unlock with the newest version of iLiberty... then tested the SIM cards before even trying to connect to iTunes again.
    2008-06-24 11:31 PM
  7. HECTOR1965's Avatar
    yes did as highflyer told me full dfu restore through itunes and then used latest iliberty+ which i only just downloaded everything went fine and i tried the 3 different sims in my other unlocked iphone to check they work. tried them in the ""unlocked"" iphone and the carrier shows in top left but will not let me recieve or make calls.
    any ideas cause im about sick of restoring now
    Cheers

    also installed cydia and updated it all through my wifi and all that seems fine
    Last edited by HECTOR1965; 2008-06-24 at 11:41 PM. Reason: Automerged Doublepost
    2008-06-24 11:41 PM
  8. hiflyer's Avatar
    Another thing you can try is to go into settings and turn off Forwarding, Call waiting, Caller Id and tty. Then reboot the phone and see it that changed anything.
    2008-06-25 12:04 AM
  9. HECTOR1965's Avatar
    ok tried that rebooted phone and getting a good 4 bar signal on a virgin mobile sim card and shows the phone number in settings so tried to ring it from my other phone to which im told calls are currently not being connected to that numberand i know it works in my other phone
    2008-06-25 12:18 AM
  10. dale1v's Avatar
    moved
    2008-06-25 01:20 AM
  11. navalynt's Avatar
    Have you ever been able to make a call from this phone? How long have you had it? Did you buy it new or used?

    I ask because if you recently purchased it used there is a good possibility it was a stolen phone and the IMEI has been black-listed by the carrier. If you have never been able to make a call it's possible the phone has a hardware fault like a bad comm board.
    2008-06-26 08:39 AM
LINK TO POST COPIED TO CLIPBOARD