1. alefedeli's Avatar
    Friends, I have my iPhone version 1.0.2, and somehow it upgraded to 1.1.2, and now displays a message of Incorrect SIM: insert an unlocked and valid SIM to activate iPhone, please help me, i've tried many different kind of guides but i cant find the right one, i have to mention that i'm living outside the US and i'm using a non AT&T SIM card. thank friends!
    2007-12-12 01:11 AM
  2. omaar's Avatar
    2007-12-12 01:51 AM
  3. defmute's Avatar
    2007-12-12 02:16 AM
LINK TO POST COPIED TO CLIPBOARD