1. Sully's Avatar
    Ok, I have searched the forum for this resolve before I posted but was unable to find the fix stated clearly.

    Either way, I've done the downgrade method, then OktoPrep, then Upgrade, then AnySim 1.2.1u.. Received, "anySim Cannot unlock this iPhone, anySIM will now quit. Please turn off you phone and tun it on again after anySIM quits." Also receive a quick secpack error, which is covered up by the above error. I've done this a few times, and tried again, same error.

    Figuring this maybe be an issue with 1.1.2, i decided to downgrade back to 1.1.1, and anySIM 1.1, I recieve the same error with anySIM 1.1 also.

    I have BSDSub, SSH, installed, and the phone is Jailbrokened. I for the life of me cannot figure out what the issue is, or which step ive missed.

    Either way, any help would be a appreciated as Ive spent a good 6 hours on the issue without a resolve.

    Many Thanks!

    Sull
    2007-12-19 05:43 PM
  2. velkr0's Avatar
    did you put the phone in airplane mode before running anysim1.2.1u on 1.1.2? i think you've gotta do that..
    2007-12-19 05:49 PM
  3. Sully's Avatar
    Yep, I followed the in-house guide to the T, exactly as it was documented.
    2007-12-19 05:51 PM
  4. sonny's Avatar
    Might be an OTB 1.1.2, which is unlockable at the moment. Even if you downgrade it to 1.1.1.
    2007-12-19 06:09 PM
  5. Sully's Avatar
    Nope this isnt a OTB 1.1.2, I purchased this (waited in line) the first day it was released.
    2007-12-19 06:44 PM
  6. chrisw05's Avatar
    Did you already unlock it because me and a guy were trying to figure out why his tmobile sim wasnt working after we unlocked it and ran it again and it said that
    2007-12-19 06:49 PM
  7. Sully's Avatar
    Great point Chris, Yes I had the iPhone unlocked in 1.1.1 w/anySIM 1.1... then one of my clients wanted to borrow the phone for awhile, not wanting them to mess anything up with "Installer" I clean restored it to 1.1.2, wiping all "mod" appz away, essentially a fresh iPhone. Upon return of the iPhone I was not able to use my T-Mobile sim anymore, thus tried the in-house guides.

    Which as you can see above have failed, and I've yet to figure out why. Did it have something to do with unlocking before? That being said, why didn't it stay unlocked?

    Sull
    2007-12-19 06:55 PM
  8. chrisw05's Avatar
    what i would do is probly jailbreak 1.1.1 then add http://i.unlock.no to your sources and then install baseband downgrader and then when its done restore 1.1.1 and that SHOULD clean things up for you
    2007-12-19 06:59 PM
  9. Sully's Avatar
    Yep, I've tried that via -> http://www.modmyi.com/forums/showthread.php?t=18096

    But when running the Baseband Downgrader i get "Main script execution failed!" error...

    My current Firmware is 04.02.13_G

    hmm
    2007-12-19 07:05 PM
  10. chrisw05's Avatar
    i think what happend to me was it gave me that error and then there was no firmware on the baseband (WI-FI greyed out) and then i restored to 1.02 and then up to 1.1 but let me know if u figure it out
    2007-12-19 07:39 PM
  11. reddevilseye's Avatar
    try guide downgrade 1.1.1 to 1.0.2 + fix seczone
    it gave me an error in phase 2 but it deleted my bb then I restored 1.1.1 so I installed new one and it worked
    hope that will help
    2007-12-19 08:01 PM
  12. Sully's Avatar
    Ok well, I again restored to 1.1.1, fresh 1.1.1 and was able to do the BB downgrade.. Restored 1.1.1 again, per instructions, and activated, AppTapp'd, and running anySIM 1.1. I dont plan on upgrading to 1.1.2... until whatever issue that is happening has been resolved. I'll update when anySIM completes, see if it worked or not.

    Big thanks to whomever runs this site -> http://iphone.unlock.no/#Unlock-the-SIM-lock

    anySIM 1.1 worked, on 1.1.1, T-Mobile up and running.. Now I just need to fix the EDGE settings to work with T-Mobile.

    Thanks for the help guys!
    Last edited by Sully; 2007-12-19 at 08:22 PM. Reason: Automerged Doublepost
    2007-12-19 08:22 PM
  13. frank1123's Avatar
    I usually run anysim1.2.1u on 1.1.1 before i upgrade to 1.1.2 and it always works.
    2007-12-19 08:56 PM
  14. seb_nkl's Avatar
    hey sully i have exactly the SAME problem could u explain me in detail what i should do plzzz

    thx
    2008-01-14 04:22 PM
  15. lordvecna's Avatar
    usually i try this:

    Iphone 1.1.1

    Install BSBsubsystem
    Install Open SSH
    Install Oktoprep
    Install AnySim 1.2u

    run unlock

    Upgrade to 1.1.2

    If i recive error from anysim, downgrade to 1.1.1 and restart the procedure.

    usually it works
    Lord Vecna

    17 1.1.1 IPhone Unlocked & upgraded
    14 1.1.2 OOB Jailbreaked
    25 1.1.2 OOB Jailbreaked H/W Unlocked

    Ipse Dixit:

    "Dear Lord, give me the ability to punch via TCP/IP"
    2008-01-14 05:10 PM
  16. treble13's Avatar
    I'm having exactly the same problem. My iPhone is a wk 43 and I think it was probably 1.1.2 OTB. I keep getting exactly the same errors.
    2008-01-14 08:05 PM
  17. damien6's Avatar
    i got my phone to work too.....
    restored 1.1.1 downgraded the bb....restored again.....ran anysim 1.1
    and it works like a charm!!!
    the iphone lives!!!!
    2008-02-03 07:38 AM
LINK TO POST COPIED TO CLIPBOARD