1. lazybirdboy's Avatar
    Stupid me upgraded to 2.0 on Friday expecting the hack to be released. So now I managed to downgrade to 1.4 but my SIM was not recognized. I've used Winpwn, Ziphone, iLiberty, and iPlus.

    iPlus seemed but still no calling capabilities. No carrier name listed. WiFi works fine though.

    So I used Ziphone again and it made it almost all the way thru before hanging. I stopped the process and when trying to restart my phone fought back!

    Now I've got a phone in a programming type of state (like Ziphone with all the white words scrolling only the words don't scroll).

    Help pls!


    got it sorted out!
    Last edited by lazybirdboy; 2008-07-14 at 11:22 PM. Reason: Automerged Doublepost
    2008-07-14 11:22 PM
  2. scincade's Avatar
    Please tell me how you got your phone back to the 1.1.4 firmware. unfortunately i did the same thing you did and upgrade to 2.0 today. Please help me . after u post it can u please email directions also cuz my wife uses computer alot for school.
    2008-07-15 05:06 AM
  3. lazybirdboy's Avatar
    I used this walkthru

    iPhone News & Review 2.0 to 1.1.4 Downgrade

    Winpwn worked best for me in step 4. I found it's all about patience. I downgraded about 12 times before things seemed to finally click. Except of course I can't unlock the sim card. I think it's my pc as I had iTunes 7.7 on here and it may have left residual files that are affecting the overall downgrade.

    Good luck!

    ps- I see you're using Vista. Get away from that and use anything BUT.
    Last edited by lazybirdboy; 2008-07-15 at 05:13 PM. Reason: additional comment
    2008-07-15 05:12 PM
  4. fuzio1963's Avatar
    Not true, about Vista. I am using it and last night i did downgraded to 1.1.4 on Vista comp.
    2008-07-15 09:15 PM