User Tag List

  1. djacobs17's Avatar
    I tried to restore my iPhone and after is was done "restoring" I got a message that says "Incorrect SIM. Insert an unlocked and valid SIM to activate iPhone." I get the same message anytime that there is a SIM card in the phone, even the AT&T SIM that came with the phone. When I connect to iTunes I get a message that says it may be damaged and that I should go to an apple store. Has anyone encountered this problem? Can anyone help me? Any help would be greatly appreciated.
    2008-01-21 04:40 AM
  2. cpjr's Avatar
    You'll have to give a little more information. Most importantly, was the iphone "unlocked" before you tried to restore it? Or are you using ATT and an ATT sim? Have you messed around with downgrading/changing your baseband version any?

    If not, you may just have a damaged simcard or try re-seating the simcard (pull it out and place it back into the phone).

    If all fails and you ARE using ATT with an ATT sim, take it to Apple and let a genius check it out, they will either resolve the problem or replace it.
    2008-01-21 04:55 AM
  3. djacobs17's Avatar
    It was unlocked and downgraded to 1.0.2, I ran into problems when I tried to restore it. I have T-Mobile, but I put the ATT SIM in to see if that would work. I took it to an Apple store and they said there was nothing they could do. Does this help?
    2008-01-22 04:57 AM
LINK TO POST COPIED TO CLIPBOARD