1. VF-x's Avatar
    Help!!

    I managed to upgrade from 1.1.1 to 1.1.2. I had to use iNdependence 1.3.2b to get it out of recovery mode, but it worked. I was able to use Installer and ssh, so I assumed that the phone was jailbroken.

    I then proceeded to get anySim 1.2.1u, and then I tried to run it. It ran, but did not appear to finish. I then pressed the Home button; which did nothing. Then I tried to shut the phone down completely.

    When it restarted, all I got was the Apple logo and the "waiting" little animated circular thing. I did some resets (Home + power), and it continues to do the same thing.

    Now when I plug it into my Mac, and start iNdependence, it complains it can't get the baseband.

    What have I done??? And how do you think I can fix it??? Or am I totally screwed?

    Any help would be appreciated.

    Thanks,
    VF-x

    OK.. Understand what I did wrong.

    I didn't know that upgrading the firmware from 1.1.1 to 1.1.2 wiped out all applications. So at the time, I didn't have BSD installed on 1.1.2, while I had it in 1.1.1.

    This likely prevented anySim1.2.1u from working properly, and likely caused some issues when I tried to reset the phone.

    My solution was:
    1. Use iTunes to restore the firmware to 1.1.2 (the file I had on hand)
    2. Follow the instructions to return to 1.1.1
    3. Jailbreak 1.1.1
    4. Follow instructions to upgrade and jailbreak 1.1.2 (I needed iNdependence to kick it out of DFU mode after running jailbreak.jar)
    5. Follow the 1.1.2 unlocking instructions making sure to have installed BSD.

    Seems like a simple set of instructions, but boy was I sh*tting bricks, as I thought I had really messed up the phone.

    I hope this helps anyone else who's run into the same problem.

    Lesson learned:
    Be aware that a firmware upgrade will remove BSD. You must reinstall it before unlocking.
    Last edited by VF-x; 2008-01-31 at 07:23 PM. Reason: Automerged Doublepost
    2008-01-31 07:23 PM
LINK TO POST COPIED TO CLIPBOARD