1. Taniban's Avatar
    Hey everyone, I'm from England and I was very fortunate in buying an american OOTB 1.1.1 iphone with bootloader 3.9 just before the new bootloader came out. I then upgraded my iphone to 1.1.2 and it is working fine. Now since the 1.1.3 is out, and after reading a lot of the threads, it seems like like google maps does not work unless either you have the new baseband or using the Locate Me trick.

    I was just wondering would I get everything working ie get google maps working and the phone unlocked on an 02 simcard IF I upgrade via iTunes to 1.1.3, then downgrade to 1.1.1 with the new baseband jailbreak and unlock to 1.1.2 and then softtouch jailbreak to 1.1.3?

    Be extremely thankful if someone can answer my question.
    2008-01-31 01:13 PM
  2. andybond's Avatar
    I hope I can help ..

    o2 PAYG user here. I used the ibrickr method of getting upto 1.1.3 , the phone worked , but no signal , i did a baseband downgrade as found on the intaller app and got my signal back.

    Locate me , and Google maps however dont appear to work.
    2008-01-31 04:30 PM
  3. Taniban's Avatar
    I'm on a standard O2 contract, (NOT iPhone contract) and thats the question I was trying to ask.. is there any way for me which I can be on an unlocked jailbreaked 1.1.3 with the new baseband with google maps working WITHOUT using Locate me trick?
    2008-02-01 07:27 PM
  4. clincoln's Avatar
    I understand what you are saying but at this moment there is no way of unlocking 1.1.3 so you can use a non contract sim on a foreign phone, I have found this out to my mistake. The problem is the baseband upgrade that iTunes does. I would in all honestly stay on 1.1.2 till an proper unlock is generated for 1.1.3
    2008-02-01 08:37 PM
  5. RickyGervais's Avatar
    The only way google maps works is by upgrading to the new baseband. The new baseband is currently unlockable therefore you cant run any non iphone sim in it.

    Sorry
    2008-02-01 09:05 PM
  6. Taniban's Avatar
    Thank You guys! Unhappy outcome but needed the closure.
    2008-02-02 02:35 AM
LINK TO POST COPIED TO CLIPBOARD