1. quangtnguyen's Avatar
    I need some help here.I had a perfect functioning jailbroken iphone but then I thought I should update it to 1.1.3. So I went about updating it to 1.1.2 and it worked. But the phone was locked again, so I ran the anysim 1.2u and it stalled on me. So my iphone was stuck in apple logo land for a while. I managed to get out of it and managed to upgrade to 1.1.3 but I forget to unlock it at 1.1.2 so I had to start all over.

    So I restored it at 1.1.1 and managed to jailbreak. I tried iphonesimfree but it says that 'unlocked failed, error unlocks is currently unauthorized or unavailable for this phone. Please contact your reseller.' I also tried Anysim from i.unlock.no had installed the program through sources, but that still didn't work. It said ' please restart your iphone. anysim cannot unlock this phone. anysim will now quit. please turn off your phone and turn it on again after anysim quites.' I am trying to get my t-mobile sim card to work.
    I made it work the first time I got the iphone, but it doesn't work anymore.

    Anyone have any idea how to resolve this.

    2008-02-04 01:17 AM
  2. jakeryaz's Avatar

    Sounds like you have done exactly the same thing as I have. Would be great to hear an answer on this, none of the anysims work after this process
    2008-02-04 01:55 AM
  3. BigBoss's Avatar
    There could be a whole number of reasons that this is happening. Most likely you people have damaged your basebands. Here are some hints. (Please do not private message me further questions. If you want help come get help on irc #iphone in irc.osx86.hu or efnet, if you dont know what IRC is, google it).

    If you moved to 1.1.2, your baseband is currently 4.02.13_G. The only unlock option is anysim 1.2.1u. First check your IMEI. If it starts with 0049, you have to try to repair the damage first. To see if it is even fixable, remove your sim card, reboot the phone and check your IMEI again. If your IMEI is 0049* with your sim card removed, you are done. You now own and unfixable ipod. If your IMEI is restored when removing the sim card, you can fix your phone. Search for downgrade, virginize, 0049 imei, or such and read the guides.

    If your IMEI is healthy (does not start with 0049 with sim card inserted), then you need to run anysim 1.2.1u in 1.1.1 or 1.1.2. There are two possible ways to do this:
    1) You run it in 1.1.1 *only* when your baseband is 4.02.13_G (not 4.01.13_G). This means you upgraded to 1.1.2, downgraded back to 1.1.1.
    2) You run it in 1.1.2 *in airplane mode*. Airplane mode should prevent the freeze up.

    If you run it in 1.1.2 without airplane mode, it will probably freeze up and likely cause you damage.

    Note: Anysim should never be run again once your phone is unlocked. You do not run it after a restore.
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.
    2008-02-04 03:01 AM
  4. quangtnguyen's Avatar
    Hey thanks,
    I did what you asked and it accepted my sim card now. Much better but it still does not want to dial out. It says no service. Any thoughts?
    2008-02-04 07:17 AM
  5. heydatsmyrice's Avatar
    Hey thanks,
    I did what you asked and it accepted my sim card now. Much better but it still does not want to dial out. It says no service. Any thoughts?
    did you restart your phone after you unlocked it? make sure the new sim is in the phone and restart it. I did for mine and it worked great.
    2008-02-04 08:27 AM