1. peaking's Avatar
    Hey Guys,
    im having trouble with my phone after the latest update to the 2.1 FW.
    I have always been using the Pwnage tool to JB/unlock my phone since the 2.0 upgrade.

    After trying to update to 2.1 using Pwnage i was getting a "error 2001" in itunes 8. The phone was jailbroken/unlockd before this with 2.0.2. At this point i decided to just use quickpwn OS X as my phone was already unlocked from 2.0.2. This worked fine.

    Problem is now when i put my Aussie sim card in its giving me "different sim detected" error and telling me to connect to itunes. Im getting a signal in the signal bar at top and am assuming i would be able to receive calls etc but cant get past that activation screen.

    When i put the original sim in im able to access the phone. I put Bootneuter on the phone via cydia with original sim installed just to try unlock just in case somethings wrong here but bootneuter tells me "nothing to do-your choices already match current setting, so theres no need to flash".

    So im stuck at the "different sim detected" screen with an ulocked JB phone. Ive been looking all over the net for a solution and have noticed a couple of people with the same problem and no answers. Anyone with same problem and more importantly anybody with any solutions?


    UPDATE: i forgot to add this is a 2G phone that was recently replaced and activated by Apple...i took it home and JB/unlocked it at 2.0.1 but had never used my Aussie sim card to test if the unlock worked at that point as i was using the ATT here in the States. Ive been reading that i may need a patched lockdown file but that was in some earlier posts for FW 1.x.x

    OK heres the solution that just worked for me:

    download patched lockdownd file from here
    RapidShare: Easy Filehosting

    SSH into phone using cyberduck/WinSCP

    navigate to to /private/var/root/Library/ and copy lockdown folder to your desktop (for backup just in case

    delete that folder from phone

    unzip downloaded patched file and upload to phone to replace the folder you just deleted

    naviagte into patched folder and make sure file pemissions are set to 644 for all files

    reboot phone...

    that worked for me!!!!
    Last edited by peaking; 2008-09-18 at 02:02 AM. Reason: Automerged Doublepost
    2008-09-18 02:02 AM
  2. k1653d's Avatar
    Thank you very much! Exact same problem I was having.
    2008-09-18 03:00 AM
  3. 99allturbo's Avatar
    I am having the same trouble but using a T-Mobile SIM card. Will try it this evening. Thanks for posting this info!
    2008-09-18 08:21 PM
  4. peaking's Avatar
    did that solution work for u guys?
    2008-09-18 11:12 PM
  5. 99allturbo's Avatar
    Yes it did, thank you!!! I just had to configure me T-Mobile internet and I'm set now. Freakin finally! Been on this for a week....

    Thank you again. )
    2008-09-19 03:52 AM
  6. peaking's Avatar
    2008-09-20 03:59 AM
  7. pulaskeet's Avatar
    i just signed up to say thanks, this worked like a charm! i was looking for a fix for this since i've unlocked many phones out of box, but none that actually have been activated before.

    just wanted to reconfirm that this does indeed work, just follow the directions on the first post.
    2008-09-21 12:24 AM
  8. Not2Stop's Avatar
    I did tried and getting the same error "Different Sim Detected".

    Below are the steps followed:
    1. Updated to 2.1
    2. Run QuickPwn 2.1
    3. Getting "Different Sim Detected" Error when i try with T-Mobile or differnet AT&T Sim
    4. If i use my iPhone activated AT&T sim it work good.

    What will need to be done to fix this ???

    Note: I'm using Windows version of QuickPwn
    2008-09-22 03:46 AM
  9. kingofthechi's Avatar
    i tried this and still get the same message when i put in a telcel sim or a t-mobile sim. Itunes wont sync anymore. I have a 2g and have bootneuter from cydia. Itunes unknown eroor occured/
    2008-09-22 04:53 AM
  10. tmoney83's Avatar
    Hi, i got the same issue after buying my brother's iphone from him and trying to jailbreak unlock it with QuickPwn 2.1, phone was running 2.1. I get through all the steps, but when I take his old Sim out and put my AT&T sim in, i get the same error. Can someone explain how to SSH into the phone and how to run those commands, I am very technical but have never been through that procedure and cannot find a reliable site. If you could give me a step by step with the commands I would really appreciate it, I want to get this thing working!!! Thanking you in advance

    Nevermind, I got it to work using IphoneBrowser 1.8... it worked like a charm, thanks again!!
    Last edited by tmoney83; 2008-09-22 at 10:47 PM. Reason: Automerged Doublepost
    2008-09-22 10:47 PM
  11. arcadeon54's Avatar
    you are a genius!!!! that worked like a charm. I upgraded from 2.02 to 2.1 with Itunes, used quickpwn to jailbreak and unlock then used ur process to let it use any sim. Thanks a million.

    the only obstacle now is that i can't send any text.
    Last edited by arcadeon54; 2008-09-23 at 01:48 PM.
    2008-09-23 01:44 PM
  12. TMaples's Avatar
    final edit: Nevermind, I figured it out and this method works!! Thank you a million times over, this is the only place I've seen that does it correctly.

    I have the same problem and am using iphonebrowser 1.8 to fix it, i deleted the lockdown folder, but how do i replace it with the patched lockdown? i tried to drag and drop but it didnt work...help?


    actually, fixed that dumb mistake. i got the patched lockdown folder in the phone using the iphonebrowser, but now i need to check to see if the file permission is 644...how do i do that? its the last thing i need to do before resetting the phone...
    Last edited by TMaples; 2008-09-24 at 02:46 AM.
    2008-09-24 02:12 AM
  13. peaking's Avatar
    hey guys,
    im glad this has been working for people...ok im not going to go thru the process of SSH'ng into the phone as there are a million places ive seen how tos posted...im sure if u dig round here u will find how to do it....u will need to DL winSCP (win) or cyberduck (mac).....how to set permissions?...on a mac which i use its hitting command + i...on a pc im not sure but it may be like right click properties?...can any pc head confirm this??
    2008-09-24 03:46 AM
  14. Not2Stop's Avatar
    Hey Guys... Glad to tell after a lot strugle i made the phone to work with different SIM cards.

    Steps followed:

    1. Use QUICKPWN 2.1 procedure to Jailbreak and Unlock.
    QuickPwn (Windows) Guide

    2. Now you need to remove the previous activation, for that you need to follow the below procedures.

    2.1 Install OpenSSH in you iphone using Cydia (search for OpenSSH)
    2.2 Install WinSCP for Windows (WinSCP :: Download)

    3. Use WinSCP to connect to iPhone
    Windows Guide To Using WinSCP With iPhone

    4. Follow the below steps:

    4.1 Download patched lockdownd file from here
    RapidShare: Easy Filehosting

    4.2 Navigate to to /private/var/root/Library/ and copy lockdown folder to your desktop (for backup just in case - this you need to do)

    4.3 Delete that folder from phone

    4.4 Unzip downloaded patched file and upload to phone to replace the folder you just deleted

    4.5 Naviagte into patched folder and make sure file pemissions are set to 644 for all files (follow the procedure in Step 3 above)

    4.6 Reboot phone

    ~~~~ YOU ARE GOOD TO GO ~~~~

    Lemme know if you have any issues.

    Note: Don't disturb other files other than Lockdown.
    2008-09-24 09:44 AM
  15. Bosephus's Avatar

    Got my Iphone today. It's running version 2.1 (5F136)

    1.) - Quickpwn 2.1 it.
    2.) - Can put different sims in, but it comes up with the error message while still showing other networks in the top left.

    3.) Tried the changed Lockdown file as above.

    4.) It still says "Differenet Sim detected", making me put the 02 sim back in an hook up to I-tunes.

    any ideas???

    Cheers in advance.
    2008-09-24 05:52 PM
  16. Not2Stop's Avatar
    Me to had the same problem, you need to do Lockdown and change the file permission to 644, reboot ur iPhone.

    This will fix ur problem.
    2008-09-25 06:12 AM
  17. Gambit80's Avatar
    I followed the directions exactly as posted and file permissions (all 3 files in the lockdown folder) were already set to 0644 but when I reboot my iPhone it brings me to the screen with the itunes and usb logo. Any suggestions or help?
    2008-09-25 06:54 AM
  18. djdownhill's Avatar
    Worked for me!

    Thanks peaking!
    My Geek Toy! <--It gets 10 MPG.....
    2008-09-25 03:25 PM
  19. Bosephus's Avatar
    Got it working today. After putting the Lockdown file onto the phone, you need to turn it off. Then turn it back on with your sim in and it should be fine.

    Worked for me first time today... finally!!!
    2008-09-25 03:54 PM
  20. Gambit80's Avatar
    My iphone is stuck in recovery mode after putting the lockdown folder where peaking mentioned. I tried to restore it using itunes but even itunes is not detecting my phone now. Can someone please help me get out of this recovery mode and help me restore my iphone so I can try it one more time? Thanks in advance.
    2008-09-25 04:29 PM
90 123 ...