User Tag List

  1. billj63's Avatar
    Hey guys...

    having a little problem.

    So i got one of those ismartphone hardware mods for the iphone 3g.

    I hook it up to the phone and it gets full signal, and 3G (on media net unlimited btw).. but the only issues is that I CAN go online and i CAN make calls... but I can only receive when I am connected directly with the tower..
    like, i may go hours without a message, but the second i get online i receive like 20 messages.. and same with phone calls... I dont get any phone calls, but when i make a call it suddenly tells me people are calling..

    anyone know how to fix this issue?

    The iphone 3g i have is currently in pwned 2.0.0 but i have tried this in .1, and .2, as well as 2.1.0

    Thanks!
    2008-09-21 08:30 AM
  2. iMack007's Avatar
    Sounds like a faulty chip. try emailing your supplier about this and request another chip....preferably i-smartphone II instead of version I.

    To be perfectly honest, I ordered the same chip as you and did my research too late. There is only one original i-smartphone manufacturer who are now on verion 2 (i-smartphone II) of this unlock solution and they claim that all others are fake versions. I looked into it a bit more and it seems true...hence dropped calls, lost signal etc.

    So whilst waiting for this unlock adapter I (after researching this time ) ordered the Universal Sim Unlocker from universal-sim.org and that has worked right out the box perfectly..I'm on day 3 with no issues at all..so far.

    Just to let you know. I just wrote off the expense of the 'fake' i-smartphone unlocker/adapter and am keeping it for use on other locked regular mobile phones etc.
    Last edited by iMack007; 2008-09-22 at 11:47 AM.
    2008-09-22 11:41 AM
  3. overbo0st2k4's Avatar
    So, it's been a few more days...Just wanted to see your progress and status with using the ismartphone chip.

    I am planning on buying this in the next day or two, so just trying to research before making the purchase.

    Thanks for any advice in advance.
    2008-09-26 12:50 AM
  4. iMack007's Avatar
    So, it's been a few more days...Just wanted to see your progress and status with using the ismartphone chip.

    I am planning on buying this in the next day or two, so just trying to research before making the purchase.


    Thanks for any advice in advance.

    I tried to unlock a supposed compatible standard SE K850i and it didn't work, so in all honesty I couldn't recommend the Brando sim unlock solution. I'm currently using the universal sim unlock solution on software version 5.5 and this is working beautifully so far .... 9 days and counting!! Everything works as with official carrier except visual voicemail.
    At this time I can o my recommend this solution as I have had no success with any other sim unlockers.
    2008-09-29 12:09 PM
LINK TO POST COPIED TO CLIPBOARD