User Tag List

  1. commandercool009's Avatar
    I would appreciate any help/ideas that anyone can offer in regards to my problem. Basically, i restored my 2G iPhone, but i don't know which firmware i am currently running, and so i cannot jailbreak/unlock/upgrade/whatever.

    The longer story: When i got it, it was running 1.1.4, unlocked and jailbroken, with a Fido SIM (canadian company). Today, i saw that 2.2 was unlocked, so i upgraded my iPhone to 2.2 with iTunes and then i used QuickPwn 2.2 (i am on mac os x leopard, but i have access to a PC if it will help) and everything was working fine EXCEPT for the phone. It showed no bars and no carrier, and i couldn't make any phone calls - everything else was fine. Foolishly, i clicked restore in iTunes and now my iPhone is in a state where it asks me to insert a valid SIM and activate. If i plug in my SIM, iTunes says it's an invalid SIM. If i put it in restore mode, i can install different firmwares. I tried 1.1.1 and it gave me an error. I tried 2.2 and that went fine, except after it finished, the iphone still gave me the "connect to itunes" and insert SIM thing. So right now, my iPhone is factory restored (to whatever version that may be) and i am lost as to what to do.

    Any help is greatly appreciated !!
    2008-12-14 05:41 AM
  2. FairLight's Avatar
    You can't downgrade from a 2.x down to a 1.x.x that easily.

    If your on firmware 2.2 at the moment, Download and install: 'PwnageTool' on your Mac.

    To check what firmware your on, From your home screen,

    Navigate to:

    - Settings > About.

    Your firmware should be displayed somewhere on that page.

    Run the program and direct it to Unlock and Jailbreak your iPhone.

    You might need a fresh copy of firmware 2.2, And in that case, A quick google of appropriate "key words" should do the trick.

    Good luck!

    2008-12-14 06:16 AM
  3. commandercool009's Avatar
    "You can't downgrade from a 2.x down to a 1.x.x that easily."

    well, i had 2.2 installed, then i clicked "restore" in itunes... its back to the "connect to itunes" and "insert SIM to activate" screen, and i cant do anything. i can put it in restore mode, i've tried installing 2.2 back, it installed, but the connect to itunes screen still shows up. i tried 1.1.1, 1.1.4, 1.1.2, all of them give me errors. i think my baseband is messed up? im not sure if that has any significance ....
    2008-12-14 06:54 AM
  4. Zwayne's Avatar
    If you update to 2.2 by itunes...your baseband was updated too, and I dont think there is a way to downgrade the baseband at this time.

    If you could find a custom made ipsw by Pwnage tool, you might be able to put the phone i DFU mode and try to load the custom made ipsw.
    Last edited by Zwayne; 2008-12-14 at 07:02 AM.
    2008-12-14 07:00 AM
  5. commandercool009's Avatar
    ok so after messing around trying to restore different firmwares (to no success), i just opened QuickPwn 2.2 up again, ran it, it did it's thing, and now my iphone is working except for the SIM card :S i can't make phone calls for some reason ...
    Last edited by commandercool009; 2008-12-14 at 08:03 AM.
    2008-12-14 07:15 AM
  6. iMack007's Avatar
    If you update to 2.2 by itunes...your baseband was updated too, and I dont think there is a way to downgrade the baseband at this time.

    If you could find a custom made ipsw by Pwnage tool, you might be able to put the phone i DFU mode and try to load the custom made ipsw.
    ****!! Really??? I thought that was only on the iPhone 3G and not the 2G version...gulp!! gotta check my shite again.
    2008-12-14 04:04 PM
  7. joshxpruitt's Avatar
    ok i have a 2g iphone with 2.2 on it , it's locked to at&t and i do not have a way to activate it at all i have tried quickpwn and pwnagetool and it just like freezes up on me all i can get the phone to do is turn on and show up the plug to screen itones some one please help i just want the dang thing to work as a ipod not even using it for a phone at all
    2008-12-14 05:12 PM
  8. commandercool009's Avatar
    2008-12-14 07:31 PM
LINK TO POST COPIED TO CLIPBOARD