1. TBbmx's Avatar
    I just updated from 1.1.4 to 2.2.1 then used quickpwn. Everything works great only I get NO wifi. It doesnt even show up, then if it does I can't connect.

    I tried to reset all network settings... Nothing
    I tried to restore and unlock/ jailbreak again.... Nothing

    I have no idea what to do! Everything else works great but I want my wifi!

    I see this is happening a lot with other people. If any one knows how to help PLEASE HELP!!

    Thank you for your time.
    2009-02-06 07:45 AM
  2. dejawoo's Avatar
    Did you try to restart your wireless router? Sometimes a reboot of the router may fix the issue.Try disable all security security,reboot the wireless router and reconnect your iPhone via Wifi.See if this works.
    Also i suggests to turn off MAC address filtering on your Wifi router.
    If you are still receiving the error message “Unable to Join Network Failure (error -3)” on the device when attempting to connect or join to your Wi-Fi network after trying the above suggestions,tap Settings > Wi-Fi > Other (under Choose a Network) and then enter the Wi-Fi Network Name(SSID) and select your Security setting and enter your password.
    Check your Wifi settings (Go to Settings -> Wi-Fi -> “>”). Did you connect to a network already?If no,one workaround is to use static IP address instead of DHCP. At the Wifi settings screen, tap “Static” and fill in the IP address and other network settings manually.
    2009-02-06 01:27 PM
  3. defiantmacho's Avatar
    So you updated your firmware to 2.2.1 thinking it was all that... well... only to find out WiFi got screwed!
    DO NOT DESPAIR. I HAD THE SAME ISSUE AND THIS IS WHAT SOLVED IT FOR ME. Firmware 2.2.1, well, sucks when it comes to WiFi functionality. Apparently, firmware 2.2.1 can not handle MAC Address filtering.
    I am doing a copy/paste of my very own solution. I am posting this on different sites so it reaches as many people as possible in the shortest time.

    Here's the final solution I found by old fashioned trial and error (AND what a pain in the butt it was to figure out). It worked, is still working and in full WiFi strength!
    I have a Netgear WGR614v6 wireless router, but I suspect it will work fine with most routers, specially Netgear.

    This is what I did:
    1- I logged into my "WiFi Access Point/Router" (Meaning the website where your router's settings are). In my case it is 192.168.1.1 (This is the set Access Point for my router. You'll need to find yours. It should be located on the back label of the router itself.
    2- Once I logged into the router's "Access Point" site, I went into "Wireless Settings" located in the menu on the left pane of the screen.
    3- Here I chose "WPA-PSK..." as the security to be used, AND, I entered a PASSWORD. This is to maintain the Network Secure and block leachers from using my internet for free!
    Don't forget to "Apply" the changes before going to the next step, and wait for it to finish will you? It will need a few extra seconds after it completes (the little antenna lights up on the router). MAKE SURE YOU WRITE DOWN THE PASSWORD!
    4- NOW, on the left pane (the menu to the left of the screen, remember?), go into "Advanced Wireless Settings". See that button that reads "Setup Access List"? Click on it! :P
    5- Once in, DISABLE "Turn Access Control On". In other words, uncheck it.
    6- Apply Changes, and for God sakes wait for it to finish!
    7- On your iPhone, go to "Settings", then "General", scroll down to the end and tap on "Reset". Don't worry. It will not reset your iPhone. It will merely bring a new menu. Now from this menu, tap on "Reset Network Settings". Let the iPhone throw its fit... it's OK!
    8- Try to log into your WiFi network using the password you were supposed to have written down in step 3 above.
    9- You should be able to connect now to your protected network with full strength and all!
    ENJOY!
    I hope this helps you as it did me...
    2009-04-01 03:57 AM
LINK TO POST COPIED TO CLIPBOARD