User Tag List

  1. GhostBot's Avatar
    Hi Guys,

    I'm really hoping someone can help here, I've been trying the unlock using the following instructions:

    Here's what's happening...

    1. I've made it to Step 7 and I'm unable to save the DFL file from minicom.
    2. I've tried to move ahead as the instructions say and I'm unable to type any commands in the minicom???
    3. After searching for the bbupdater -v, it seems that this IS supposed to be ran after the 20 minute reflash, but when I've run this from the SSH window I get Permission Denied: bbupdater

    So here's the questions:

    1. After this 20 minute flash, do we need to run the bbupdater -v command?
    2. If so, where do we get, where do we place it, how do we run it so that we don't get a permission denied?
    3. After running the bbupdater or not, should we be able to save a DFL (minicom config file) to the device?

    Possibly a Huge Frickin' problem:

    I've been following these instructions to the letter and I've seen nowhere until I did a search outside this site that you have to save your original '' file. I did NOT do this and am wondering now if I've bricked the phone? Please tell me this wasn't an error on the instructions!

    Thanks for the help

    I'm running this on Mac if that matters...
    Last edited by GhostBot; 2007-09-12 at 10:09 AM. Reason: Automerged Doublepost
    2007-09-12 09:57 AM
  2. SundayDuffer's Avatar
    Are you sure you have all the files needed?
    There are 7 files total...

    bbupdater, nor, iUnlock, lockdownd, ICE03.14.08_G.fls, minicom, minirc.dfl

    go here and follow the worked for me the first time i tried with no mishaps. If you dont have all the files..go to the top of this link and download them...

    2007-09-12 10:11 AM
  3. GhostBot's Avatar
    Ok, I think we're good, actually we are good, I've managed to finish this update and everything is working. So here's what I did to get past these instructions.

    First things first, I would not recommend that you use these instructions here:

    While they do work, they are not complete. Instead use the ones which were pointed to by SundayDuffer (thanks btw, this was a good place for finding the information necessary to unblock me). His link was:

    Ok, so onto the fix:

    1. I had installed the bbupdater binary in the /bin directory but failed to chmod +x it. So once I did this I was able to perform this before continuing to Step 7. I would call this step 6.5 ;-)

    2. Once the chmod +x was complete, I ran the bbupdater -v and got all the useful output. I then moved on and was still unable to save my DFL file but as I understand this is just a defaults setting file and only useful if you plan on running minicom in the future; so I skipped this.

    3. After entering minicom I was then able to enter the commands as necessary and the rest of the steps worked as advertised.

    4. Missing from the original install link which I provided was the LockDown file which I was able to get from the link SundayDuffer provided, I added this to the appropriate directory and then considered it finished.

    5. I also did some checking and the file does not need to be backed-up and reapplied. Found this out on a faith of god move where I rebooted and everything worked.

    General Caveats with the process:

    1. There was a mistyped command in step 10. the notes said:

    /bin/launchctl load /System/Library/LaunchDaemons/

    What was missing here was the 'load -w', otherwise I was unable to load the CommCenter

    2. This process is evolving fast. If someone by chance reads this I would recommend they wait the couple of hours likely needed and get a full graphical installer which avoids these potential issues. But if you've made it this far you couldn't wait :-)

    Ok, that's all. Thanks again SundayDuffer, the link worked and my phone is now functional.

    2007-09-12 11:15 AM
  4. manikchil's Avatar
    Hi , i just bought a iphone with version 1.1.2 already installed in it .. is there any way to unlock that phone ? or will it b possible to unlock it by any chance in future . i can only jailbreak it by degrading it to 1.1.1 but the sim lock still cant b deactivated by using ANYSIM 4.01 OR 4.02 . I m using Mac ..
    2007-12-11 04:51 PM
  5. Sigma0's Avatar
    Hi, could you please tell me how to chmod the bbupdater file? Many thanks.
    2007-12-13 03:14 AM