1. khiphone3g's Avatar
    Ok, I actually got the Wi-Fi to work by doing the Reset Network Setting, but it is bugging me knowing that I can't just reboot the phone without having to deal with it.

    Here is the story, I got two 3Gs, white and black. I got the white one working without any problem. I do not have to Reset Network Setting; however, the black one doesn't seem to act the same way. Every time I reboot, I have to Reset Network Setting.

    I jailbroke both of them with redsnOw and unlocked with ultrasn0w.

    My question: does anyone have the same problem? how you get rid of this problem completely, meaning not having to worry about doing the Reset Network Setting after reboot?
    2009-07-09 05:54 AM
  2. kakeashi's Avatar
    i have the same problem with your black one but i have a white one lol. but yeah its just the ultrasn0w i believe. maybe an update would fix it. very very annoying
    2009-07-09 07:10 AM
  3. khiphone3g's Avatar
    now the wifi doesn't even work on my black one unless i removed the ultrasn0w.
    2009-07-09 07:38 AM
  4. tinakor's Avatar
    I have the same problem when I remove UltraSn0w my WiFi working fine.
    2009-07-10 03:09 AM
  5. Poseidon79's Avatar
    Try to jailbreak on a Mac. I have been observing this issue for a while now and I think it could possibly be a bug with the windows version of the jailbreak. Report back.
    2009-07-10 03:34 AM
  6. Hurlee555's Avatar
    I say you're lucky to even get Ultrasn0w! I can't even get wifi to unlock the stupid thing. Don't do it! It's not worth it yet!
    2009-07-10 05:06 AM
  7. gladesmellzgood's Avatar
    Try to jailbreak on a Mac. I have been observing this issue for a while now and I think it could possibly be a bug with the windows version of the jailbreak. Report back.
    I jailbroke my iPhone on my mac but instead of no wifi i got really bad wifi signal and speed. And I also got locked into Edge for some reason. As soon as I uninstalled ultrasn0w they were no more issues.
    2009-07-10 07:07 AM
  8. IPHONEPLZZ's Avatar
    to remedy this i did the airplane/reboot/airplane off method and just messed around turning wifi and 3g on/off before i rebooted, it works, you just might have to reboot 2 or 3 times to get your wifi back, and this wifi problem is not related to the jailbreak , just on ultrasn0w, i jailbroke twice and i only lost wifi after using ultrasn0w
    2009-07-10 07:17 AM
  9. khiphone3g's Avatar
    The trick I am using is to Reset Network Setting. It works fine. I get Wi-Fi until next time I reboot, and I have to do the Reset Network Setting again. I am fine with that but it just bugs me to think that I have to do that every time, especially when the white one I bought the same day is working flawlessly after ultrasn0w.
    I began to think that there must be something to do with chips they put in these new phones...maybe different wi-fi chips from different manufactures and some are not compatible with ultrasn0w.
    2009-07-10 10:29 PM
  10. nodaicrag's Avatar
    I guys, I'm a newbie to this, but I jailbreaked my 3G (using it on T-mobile, windows XP, firmware 4.26.08) with Redsnow .72 and the wifi wasn't working, which therefore I couldn't use cydia to get ultrasnow to unlock. I just tried using redsnow .8 to jailbreak but still no wifi. I tried resetting network settings, turning off airplane mode, etc, but still now wifi. Any suggestions? I appreciate it your help much!
    2009-07-10 10:45 PM
  11. fiya's Avatar
    Had the same problem, jail breaking on osx or xp didn't make much of a difference.

    I tried this and so far it's working.

    Turn airplane mode on, go in to cydia, uninstall ultrasn0w.
    Reboot the phone.
    (Turn airplane mode back on if it was turned off), turn wifi on, connect to your wifi network, reinstall ultrasn0w.
    Reboot.
    Turn airplane mode off, see what happens...

    Hopefully it works for you, worked for me.
    2009-07-10 10:49 PM
  12. nodaicrag's Avatar
    Thanks for the help, but I can't even get to the unlock part. I just did the jailbreak only on redsnow. I can't even get to download ultrasnow on cydia because I can't hookup to my wifi. Any other suggestions? thanks.
    2009-07-10 10:54 PM
  13. fiya's Avatar
    If you have an AT&T sim, do a restore and start over...
    2009-07-10 11:47 PM
  14. ravi123's Avatar
    After unlock Iphone 3GS with ultrasn0w,your carrier working 100%!But wifi search failed!!

    FIX YOUR WIFI!!!

    1/Remove ultrasn0w in cydia!-->no carrier

    2/Dowloads tool:ultrasn0w fixed!

    3/Open wifi and connect to your router.use Cydia intaller "open SSH"!

    4/Open winSCP on your computer and connect to your iphone!

    5/Open Folder Media (source /private/var/root/Media )

    6/In Media folder you make Cydia folder.

    7/Open Cydia folder make AutoInstall folder.

    8/Copy ultrasnow.debfile to AutoInstall forder!

    9/Restart Your Iphone 3GS (2 restarts)
    finished! Carrier and wifi working 100%
    fix sync app failed
    Copy installed file to /usr/libexecand Sync app cracked!!
    Good luck
    2009-07-11 01:46 AM
  15. Poseidon79's Avatar
    What exactly did you "fix" this is file to make things work?
    2009-07-11 01:59 AM
  16. nodaicrag's Avatar
    Thanks all, I got it working now, and much thanks to iphone Dev Team. I read some other thread where somebody simply reset their router to just "g" only. I tried it and for some strange reason, it works now. I think more likely it was just resetting the router for me did the trick. I don't see how resetting to G only would get it to work, but it does now. More likely just some dumb error on my part.
    2009-07-11 08:29 AM
  17. awl168's Avatar
    After unlock Iphone 3GS with ultrasn0w,your carrier working 100%!But wifi search failed!!

    FIX YOUR WIFI!!!

    1/Remove ultrasn0w in cydia!-->no carrier

    2/Dowloads tool:ultrasn0w fixed!

    3/Open wifi and connect to your router.use Cydia intaller "open SSH"!

    4/Open winSCP on your computer and connect to your iphone!

    5/Open Folder Media (source /private/var/root/Media )

    6/In Media folder you make Cydia folder.

    7/Open Cydia folder make AutoInstall folder.

    8/Copy ultrasnow.debfile to AutoInstall forder!

    9/Restart Your Iphone 3GS (2 restarts)
    finished! Carrier and wifi working 100%
    fix sync app failed
    Copy installed file to /usr/libexecand Sync app cracked!!
    Good luck
    Can you explain what this fix actually does? Also, would you need to reinstall ultrasn0w after?
    2009-07-13 01:18 AM
  18. Agent Smith's Avatar
    I jailbroke my iPhone on my mac but instead of no wifi i got really bad wifi signal and speed. And I also got locked into Edge for some reason. As soon as I uninstalled ultrasn0w they were no more issues.
    This is exactly what was happening to my 32Gig 3GS Black.

    Untill the Dev Team fix this issue I will have to stay off Ultrasn0w.
    2009-07-15 12:27 PM
LINK TO POST COPIED TO CLIPBOARD