1. arbinoypogi's Avatar
    Hi!

    I know there's a ton of similar threads already about the situation I'm in right now but I can't seem to find a thread that exactly matches mine (or I just haven't browsed enough).

    I bought my iPhone 3G unlocked and jailbroken (v2.2) already here in the US. I'm actually from the Philippines and just staying in the US for a while. Ii've been using a Philippine SIM card ever since i got the iPhone and did not have any problems with it (works even in the Philippines).

    however, I attempted to upgrade my iPhone to firmware 3.0 (via restore) last night and got stuck with the invalid SIM error. so I've been reading the forums and it seems that I need the original SIM card that came along with the iPhone (I'm assuming it's an AT&T SIM card) to activate the iPhone.

    the problem is, I got my iPhone 3G as second hand from eBay and I did not get the original SIM card. can I use a different AT&T SIM card to activate the iPhone? I saw a thread saying that the SIM's IMEI and ICCID should match the iPhone's in order to activate it. is this true?

    I'd appreciate any assistance.
    2009-08-05 04:17 PM
  2. alvink83's Avatar
    Hi, you need to jailbreak and unlocked the iPhone 3G again since you have restored your iPhone. You can refer to this guide.


    Cheers~~~
    2009-08-05 04:44 PM
  3. arbinoypogi's Avatar
    thanks! but my problem is I'm unable to activate my iPhone again after I've restored it to 3.0. iTunes is saying the I have an invalid SIM card and I need the correct SIM card to activate the iPhone. i think the guide you sent me will work but I need to get the iPhone activated first.
    2009-08-05 05:02 PM
  4. Bo Troxell's Avatar
    I would agree with the poster, Jailbreak and unlock your phone. Don't worry about the sim error message, once you complete the process you'll be fine.
    You can follow the link provided in post #2 for the unlock or go here for J/B and unlock instructions.
    2009-08-06 09:19 PM
  5. arbinoypogi's Avatar
    thanks for responding blkcadi!

    well i think my problem is i can't activate my iPhone after i upgraded it to 3.0 using iPhone1,2_3.0_7A341_Restore.ipsw (option+command click Restore) via iTunes. I believe the upgrade was successful since I did not encounter any error message during the restore process. however, when the iPhone rebooted after the restore, iTunes was telling me that I need a valid SIM card (I assume AT&T) to activate it. i am stuck where there's the iTunes logo and USB cable on the iPhone screen (and where you can only do emergency calls).

    does this mean I need the original SIM card that came along with iPhone in order to activate it? can I use a new AT&T SIM card to activate it?

    i believe the jailbreak instructions specifies that the iPhone must be running on 3.0 before you can jailbreak it using Pwnage or RedSnow. unfortunately, I can't turn on my iPhone to jailbreak it since it is asking me for a valid SIM card to activate it.
    2009-08-06 10:41 PM
  6. Bo Troxell's Avatar
    thanks for responding blkcadi!

    well i think my problem is i can't activate my iPhone after i upgraded it to 3.0 using iPhone1,2_3.0_7A341_Restore.ipsw (option+command click Restore) via iTunes. I believe the upgrade was successful since I did not encounter any error message during the restore process. however, when the iPhone rebooted after the restore, iTunes was telling me that I need a valid SIM card (I assume AT&T) to activate it. i am stuck where there's the iTunes logo and USB cable on the iPhone screen (and where you can only do emergency calls).

    does this mean I need the original SIM card that came along with iPhone in order to activate it? can I use a new AT&T SIM card to activate it?

    i believe the jailbreak instructions specifies that the iPhone must be running on 3.0 before you can jailbreak it using Pwnage or RedSnow. unfortunately, I can't turn on my iPhone to jailbreak it since it is asking me for a valid SIM card to activate it.
    If your at the usb logo, put in DFU mode, restore to a fresh 3.0 close iTunes and run the jailbreak and unlock with ultrasn0w.
    2009-08-06 10:44 PM
  7. arbinoypogi's Avatar
    do you have a link where i can download pwnage or redsnow?

    oh never mind. i found it. i will attempt jailbreak now. thanks!
    Last edited by arbinoypogi; 2009-08-06 at 10:50 PM. Reason: Automerged Doublepost
    2009-08-06 10:50 PM
  8. Bo Troxell's Avatar
    Do not try to point iTunes at the .ipsw that you download for the jailbreak, just restore and then run redsn0w.
    2009-08-06 10:53 PM
  9. arbinoypogi's Avatar
    thanks blkcadi and alivnk83! all i needed to do was to jailbreak the damn thing. LOL! i'm now have iPhone 3G running on 3.0, jailbroken and unlocked.
    2009-08-07 06:53 AM
  10. Bo Troxell's Avatar
    Awesome, glad it worked out for you. Enjoy
    2009-08-07 07:12 AM
  11. infamous12550's Avatar
    thanks blkcadi and alivnk83! all i needed to do was to jailbreak the damn thing. LOL! i'm now have iPhone 3G running on 3.0, jailbroken and unlocked.
    What are you using for the unlock? Ultrasn0w?
    "Win or lose, I promise you violence"

    Wanderlei Silva
    2009-08-07 11:20 PM
  12. alvink83's Avatar
    Should be unlocked by installing ultrasn0w. Just add it to your Cydia installer and install.

    But, previously he was having problem on jailbreaking his iPhone.
    2009-08-08 03:43 AM
  13. infamous12550's Avatar
    Should be unlocked by installing ultrasn0w. Just add it to your Cydia installer and install.

    But, previously he was having problem on jailbreaking his iPhone.
    I was asking because I am having the same issue as tons of other people with ultrasn0w not working. It gives you service for a few seconds & then nothing. I have restored numerous times, used redsn0w, untrasn0w, I even tried out purplesn0w even though I dont have a 3gs. Nothing is working for many people. This is the first time I have not been able to find a fix... Driving me nuts!
    "Win or lose, I promise you violence"

    Wanderlei Silva
    2009-08-08 05:33 AM
  14. ziga's Avatar
    If your at the usb logo, put in DFU mode, restore to a fresh 3.0 close iTunes and run the jailbreak and unlock with ultrasn0w.
    thank you very much god bless you and hope to see more help from you. YOU'RE THE MAN!!!!!!!!!!!!
    Last edited by ziga; 2009-12-02 at 01:59 PM.
    2009-11-05 09:38 PM
  15. nachobel's Avatar
    ......it's actually "You're". Kind of embarrassing when it's that big and incorrect, no?
    ----
    Cheers!
    2009-11-05 09:41 PM
  16. Smithy365's Avatar
    Ha ha ha!
    2009-11-05 10:15 PM
  17. superchicken73's Avatar
    restored, need sim.. usb and itune logo..i know i need to put it in the mode but the problem is i cant get it to shut down.. it will go black and the swirly shows up then it locks, then goes back to usb/itune logo... how do i get it to do into the mode if i cant get it turned off?
    2011-02-22 06:42 AM
LINK TO POST COPIED TO CLIPBOARD