1. PaneraiLover's Avatar
    If it was just so easy. This phone did not unlock my T-Mobile Sim with redsn0w like you mentioned, i tried to restore and JB 15 times before I started looking at other routes and ended up with this situation.. then i could not go back and put 2.2.1 FW and JB with quickpwn, what SIM do you have on your 2G that you have 3.0.1 JB with redsnow, ATT?

    OK as some of you suggested since now it looks like I was successfully Restored iPhone with 1.1.4 FW but still it didn ot Flash my Baseband and I am still missing all the hardware FW for wi-fi and the phone and still have Repair Needed POP UP on the screen, I upgraded the iTunes to 8.2.0.23 and tried to Shift Restore from DFU mode to 3.0.1 FW I downloaded as a iswp file, but still got error 23 in iTunes:



    And as some of you suggested to try to JB with iLiberty+ and then transfer needed files to iphone with Total Commander (which I still do not know how to do) and then use Mobile Terminal to run commands and programs to manually force firmware missing on to the iphone CommBoard and see if it works, I follow correct steps but get this error in iLiberty:


    How can I JB if iLiberty needs phone to pair withitunes but i do not have ATT SIM so the 7.5 itunes does not see the phone so as I assume will then allow iliberty to JB the phone so I can do the following to proceed, am I missing something?!
    Last edited by PaneraiLover; 2009-09-02 at 03:10 AM. Reason: Automerged Doublepost
    2009-09-02 03:10 AM
  2. PaneraiLover's Avatar
    Downloaded Kiphone. Got it to run by putting phone in Recovery mode as per iliberty bottom screen. Selected downgrade and debug, it started running scripts on the iphone screen and got stock on Attempting .... all over the screen on each line and thats it! I guess it did not want to do it maybe because there is nothing to downgrade if Bootneuter flashed clean the baseband, unless I am doing something wrong.

    Tried putting my friends ATT SIM, itunes still says to put valid sim!! So that did not work. I will Shift Restore to 1.1.4 for now. Any suggestions how to JB this phone in 1.1.4 so I can use the Mobile Terminal and with command prompt maybe put the baseband like other threads people did?

    I called apple they said this phone has 11 months worth of warranty left, so as long as they do not see any unlocking or jailbreaking software on it, I can just say it crashed while upgrading, then I tried to restore and it only restored to 1.1.4 after reading bunch of stuff on line and apple forum, bla bla bla, I will go with my friend who got this phone for me with att sim, apple people on the phone said no matter what I will leave with working phone, they will try to restore they said.. will they see anything on iphone if I restore to 1.1.4 like I did before?!

    Tonight I will try for the last time to JB the 1.1.4 FW so I can put Mobile Terminal on it and try to ienew app on it manually. How can I JB this phone if Kiphone did not work and iliberty does not work and gives me error messge?! Can someone tell me step by step instructions how to do it? As far as fresh payloads and in what state the phone needs to be.. I followed instructions and phone gives me this error I posted a pic off that it needs to be paired with itunes, but how can it if it is not JB and no ATT valid sim, itunes rejects it due to not valid SIM..

    Also respond to my last post as well..

    just read on other threads, and now I think I know why I was not able to unlock the phone after 20 times trying to JB it with t-mobile sim before I ended up with a brick!! I might have had to get a NEW SIM, I read a lot of people has same issue and were able to make it work with 3.0 FW with new sim. Also I read that some people had same issue like I did with redsn0w on 2G phone unlocking it, eventhough BootNeuter ran its thing at the end of each JB sesion I did, I did not see it installed in the packages in Cydia, I just remembered!! That is why I was able to manually add it and kill my phone after unsuccessfully try to unlock it, maybe I needed a new SIM all along or maybe my Bootneuter did not do its thing even if it did look it did install at the end of redsn0w?! Some people had to manuall do it, something to do with CommCenter not turning off during redsn0w to do the BootNeuter, and had to manuall ydo it by downloading it, that is what I read, so I thought to add the observation here to possible cause of my initial problem unlocking my 2G with redsn0w! Or maybe my Bootloader files were corrupt?! Anyway, thats in the past, I need to fix the brick first or have apple replace it possibly if I do not fix it by Wed next week, we will go to apple with restored 1.1.4 FW and play dumb.
    Last edited by PaneraiLover; 2009-09-04 at 08:30 PM. Reason: Automerged Doublepost
    2009-09-04 08:30 PM
  3. PaneraiLover's Avatar
    I think I am getting somewhere.

    After Kiphone as per below did not work for me. I tried to to make the iplus and iliberty to work. iliberty still give me the error in recovery mode of the iphone "error communicating with iphone, make sure iphone is paired with itunes?! Then I figured out that iplus is dos based command based app and worked for me only in Recovery mode (by the way no tutorials on here or anywhere mention it)

    I ran iplus [-u] first from CMD DOS screen, then rebooted iphone because it looked like it got stock both on iphone and on CMD screen on the 2nd process for unlock/downgrade and activate, the JB process succeeded and I was able now to see iphone files through Total Acess and now can put files on it to run manual commands in Mobile Terminal!! Look at the pics.. But looks like I got an error on 2nd step, look at pics, on iphone it says payload was not found. In iplus directory there is a payload ZIP, can someone help as far as what I did wrong or what to do now to activate and unlock, so I can get inside the phone to do next steps, I am still in emergency calls mode on iphone.

    I ran iplus from iplus2.0 directory on C by typing obviously iplus, and pressed enter. And as it went.. then I got this following screen and it was in that position for 20min, I rebooted:













    I took some pics during the loop process prior to today when I tried Kiphone and it did not work, I unplugged, and it was looping, so I had to restore, see if maybe data on these pics will help you help me, here:


    2009-09-05 11:57 PM
  4. PaneraiLover's Avatar
    so can anyone help as per below?
    2009-09-08 05:45 PM
24 12
LINK TO POST COPIED TO CLIPBOARD