1. Bogwon's Avatar
    I hope I'm posting this in the correct place. I'm new to the iPhone. Had a iTouch, sold it and want to buy a 3G and use with T-Mobile. My question is am I wasting my time buying a 3G which has 3.1 installed? I have read in posts that it is now possible to unlock from 3.1 with the 3G. All the "unlock" people I have talked to say it is not possible and might not ever be because of changes made to iPhone with new update 3.1. Obviously I don't want to buy the upgraded 3G and waste the money. Thank you for any help......
    2009-10-02 06:01 AM
  2. Bo Troxell's Avatar
    Welcome to MMi,
    If it has been updated to 3.1 the baseband has also been updated and can not be unlocked, perhaps ever. You need to find one on 3.0.1 or 3.0 to unlock for T-Mobile.

    Thread moved to correct forum.
    Last edited by Bo Troxell; 2009-10-02 at 06:05 AM. Reason: Automerged Doublepost
    2009-10-02 06:05 AM
  3. sportygurl_014's Avatar
    I have a quick question if it is impossible to unlock why are people posting videos on how to unlock and jailbreak using 3.1 firmware? Can you help me i just recently purchased an iphone with 3.1 firmware and i was hoping to unlock it.

    heres an example..

    [ame]http://www.youtube.com/watch?v=ZVHjy_d_XVg&feature=related[/ame]

    It seems to work but im unsure because i havent tried myself.
    2009-10-03 01:35 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.