User Tag List

  1. Chilewile007's Avatar
    I am new to jailbreaking. After a couple days of tireless work, frustration, and errors, I miraculously jailbroke my iphone with blackra1n.

    After all that though, I don't have service for my iphone. No carrier icon appears (is it supposed to? I have AT&T), and it either has a couple of lines or says "No Service."

    The wifi, however works just fine (if that matters).

    So down to my question. What now? I could just be missing a step, I guess. Do I need to "unlock" this iphone, and if so, how do I do that?

    Additional information: I am not signed up with AT&T for a data plan or anything like that. I just popped my old sim card into a friend's old, restored, deactivated iphone. So yes, I have AT&T, but I technically shouldn't have an iphone.

    Update: I just tried the latest version of redsn0w to unlock. Didn't work, just like all the other times I've tried it.

    Edit: problem fixed.

    I used the guide here.
    Last edited by Chilewile007; 2010-02-18 at 03:10 AM. Reason: Automerged Doublepost
    2010-02-18 03:10 AM