1. k20z1's Avatar
    Last night I unlocked my iphone. It was on 3.1.2 with 5.11 bb, I jailbroke it with blackra1n and that went pretty smoothly. After that I installed blacksn0w via Cydia and when I rebooted the phone it got stuck in the apple logo boot loop.

    What does this mean for my phone? Can I restore it somehow? Did I do anything wrong while installing?
    2010-04-21 03:43 PM
  2. Poseidon79's Avatar
    I've only seen this happen when the phone has been updated to 3.1.3 with baseband 5.11.07. Blackra1n doesn't work at all on 3.1.3. If you jailbroke with blackra1n.. why didn't you just use the blackra1n to install blacksn0w too? I would suggest restore to 3.1.2 then use redsn0w to jailbreak.. set the phone up as new in iTunes.. then install blacksn0w from Cydia again and see what happens.
    2010-04-21 04:55 PM
  3. k20z1's Avatar
    Poseidon79, thanks for the reply. I don't think I saved the SHSHs, what are my options for restoring to 3.1.2?
    2010-04-21 05:05 PM
  4. Poseidon79's Avatar
    The only thing left would be to find and download a custom 3.1.2 firmware from pwnage tool and try and DFU restore to that. There's the "once jailbroken always jailbroken" rule which means once you've pwned your phone you can always restore to a custom firmware; however you didn't use a Dev Team tool.. you used blackra1n.. so I don't know for sure if that applies in this case. Test and find out.
    2010-04-21 05:12 PM
  5. k20z1's Avatar
    Poseidon79, wow!! Thanks for the help! I was able to restore to a custom firmware from Pwnage Tool like you suggested, it took me a while cause the phones battery died and I couldn't get it to restore or DFU without it going to the battery screen...anyways, got 3.1.2 installed and running. What do you suggest now? Blacksn0w from Cydia?
    2010-04-26 03:04 AM
  6. madczech's Avatar
    strange that you were able to restore with a 3.1.2 fw as apple does not support it anymore...

    yap thats what I would do... try blacksnow again
    I don't give a damn about Chuck Norris, Spongebob can grill under water!

    2010-04-26 11:21 AM
  7. k20z1's Avatar
    it was a custom firmware, not sure if that makes a difference?

    next issue: i tried to update cydia and as it started i get the error: NetDB: Open nodename nor servname provided, or not known

    do i reboot and try again, or is there a fix for this?

    EDTI: Well I figured out what the problem was with Cydia, so I was able to install blacksn0w. BUT when I rebooted the phone it got stuck in the boot loop just like the first time!! I'm ready to pull my hair out. What am I doing wrong??
    Last edited by k20z1; 2010-04-26 at 02:57 PM. Reason: Automerged Doublepost
    2010-04-26 02:56 PM
  8. mavrik101's Avatar
    Makes all the difference. Custom firmware doesnt go thru apple's servers, so no verification.

    Are you using a 3g or 3gs? I had the same problem with a 3gs. Tried for over a month to unlock, but stuck in boot loop. If 3gs, this is what finally worked for me:

    http://extechblog.wordpress.com/2010...file-solution/
    Last edited by mavrik101; 2010-04-27 at 07:53 AM.
    2010-04-27 07:49 AM
  9. k20z1's Avatar
    mavrik101, that did it! thanks so much, i was going crazy trying to figure out why it wasn't working, even with blacksn0w rc2. wow, what a relief. thanks again!
    2010-04-27 03:25 PM
  10. mavrik101's Avatar
    Glad to hear it! Yea, it drives you nuts cause you re doing everything right and it still wont work.
    2010-04-28 05:02 AM
  11. mrknister777's Avatar
    Hi community

    If you have installed blacksn0w after successfully jailbroke iPhone and ya device freezes...

    I have a fix for that.
    Its easy.

    Only for Users who isntalled 3.1.2 cfw and problems with installing blacksn0w.
    If device freezes for no apparent reason.
    I can get a fix for that.

    PM

    Greetz
    2010-05-01 02:19 AM
LINK TO POST COPIED TO CLIPBOARD