1. ozarka's Avatar
    So i updated my iphone 3g to 3.1.2 with 5.11 and use blackrain and i used the blacksnow for unlock, but tmobile still doesnt show, all i see is no service.

    i then restore my iphone to 3.0 firmware with modem 4.26 and used ultrasnow, and still no service.

    Now the question is whether this is a software issue or a hardware issue, ie either my antenna has gone bad or wth is the problem? I know my sim card is working, because i tested it in another tmobile phone.

    If its the antenna, cant i just buy one of those replacement parts on ebay for like 5$ and attach it on?


    Who else has this problem?? Nlacksnow and ultrasno both dont work
    All i get is no service or searching then no service.....
    2010-04-25 09:56 AM
  2. cousinphil's Avatar
    Having the same problem myself. I'm almost positive it's a software problem. I'm on AT&T but I don't have an iphone contract so I need a phone that is unlocked. I think that Apple has coded something into the updates that gives you no phone service. I have another older jailbroken/unlocked iphone that works great on AT&T with no contract. No problem with that one. I don't dare update it.
    "Travel light, live light, spread the light, be the light"
    2010-04-25 06:32 PM
  3. oo3's Avatar
    Just a crazy question but did you make sure 3G was turned OFF?
    2010-04-26 04:47 PM
  4. mavrik101's Avatar
    Are you using factory firmware or custom? Ive had reception issues whenever i unlock 3g iphones and use factory firmware. Had this happen just a week ago. Restored 3 times with factory, no signal. Restored with custom, worked the first time.

    Also, since your at 4.26, you should be able to upgrade to 3.1.2 and use ultrasn0w to unlock. Custom firmware wont upgrade your baseband.
    2010-04-27 07:45 AM
  5. cousinphil's Avatar
    iTunes wouldn't let me restore with custom firmware. "Unknown error." I tried it a bunch of times with various versions of Pwnage Tool. NG. I think it's because the iPhone was upgraded to 3.1.3. I've listed that phone on eBay. I'll try again with one that's never been upgraded.
    "Travel light, live light, spread the light, be the light"
    2010-04-27 02:13 PM
  6. ozarka's Avatar
    nice, ill try a custom firmware restore tonight and see how things go, but who has a link for a custom 3.1.2 firmware?

    Right now my iphone is just getting and dropping service here and there. Its so random.

    hold up, if i try to use a custom firmware 3.1.2 and iget the 1602 error, does taht mean
    i have to
    use ireb and do all taht stuff to bypass the code? cause i see some people saying ireb's not working for 3.1.2?

    @marvik
    How you use the custom firmware when restoring and not getting any error?
    Last edited by ozarka; 2010-04-29 at 07:52 AM. Reason: Automerged Doublepost
    2010-04-29 07:52 AM
  7. mavrik101's Avatar
    Just restore as usual, but hold shift then click restore, and choose the custom firmware. If I get an error, just keep trying. Google the error to see if there is a known fix.
    2010-04-30 07:44 AM
LINK TO POST COPIED TO CLIPBOARD