1. chdesign's Avatar
    Hey guys I have a 16GB 3G iphone that I have been trying to unlock for a couple days now. I've done all the standard stuff like doing a restore and jailbreak with redsn0w then unlock with ultrasn0w and this worked beautifully with both the other 8GB 3G iPhones I have....however when it comes to this one its being a pain. The jailbreak works fine but the unlock keeps giving me a NO SERVICE up in the corner. When I go into carriers it lists both tmobile and att but it won't connect to my tmobile carrier. I've done the network settings reset and the airplane mode tricks with no prevail. Any thoughts or tricks? Here are my specs
    IOS 4.0
    Baseband 5.13.04
    model MB499LL

    Please help guys!
    2010-07-17 05:51 PM
  2. phatcamaro's Avatar
    If you have a Mac try using pwnagtool. I had success using that to JB on 4.0. Snowbreeze is the PC version I believe buy have not tested with it yet
    2010-07-17 06:37 PM
  3. Go Gators's Avatar
    Make sure you have 3G turned off in Settings, General, Network.
    2010-07-17 07:11 PM
  4. chdesign's Avatar
    yeah I have the 3G turned off....if I try to manually select the tmobile network it gives me the network lost error. If I put it in automatic carrier it just searches and searches and then gives me the no service message.

    Oh yeah I was able to jailbreak just fine....just can't get the unlock to work.

    I was able to downgrade my baseband to 4.26.08 withfuzzyband.....gonna try the unlock again.

    OK guys I've tried a TMobile and an AT&T sim and both of them give me no service at the top.....in carriers it still picks up both at&t and tmobile but it won't connect to a network! Please someone has to of had this problem before!
    Last edited by chdesign; 2010-07-17 at 10:19 PM. Reason: Automerged Doublepost
    2010-07-17 10:19 PM
  5. Rapala167's Avatar
    yeah i've had this problem but your not going to like that i never found a soloution for it :/ so i have a gloryfied ipod touch .... lame
    I don't suffer from insanity ..... i enjoy every single day of it
    2010-07-17 10:22 PM
  6. ozarka's Avatar
    look at my posts. same problem. no solution. no fix. dont know wtf is wrong
    Common Sense.
    2010-07-18 02:04 AM
  7. eyeRobot's Avatar
    Tried a jailbreak with sn0wbreeze then ultrasn0w?
    2010-07-18 11:58 AM
  8. chdesign's Avatar
    Yup done all that....even tried an AT&T sim and it still didn't work...I'm thinkin its hardware...I'm gonna send it to have someone look at the SIM pins to make sure one of them hasn't burnt out.
    2010-07-19 02:13 AM
  9. haissk's Avatar
    Can you see Ultrasn0w in Cydia??
    2010-07-19 05:01 AM
  10. Rapala167's Avatar
    Yup done all that....even tried an AT&T sim and it still didn't work...I'm thinkin its hardware...I'm gonna send it to have someone look at the SIM pins to make sure one of them hasn't burnt out.
    there is no need to do that its not the phone hardware its the software ..... i'm guessing your bootloader is 5.9 or higher thus the unlock at this time will NOT work
    I don't suffer from insanity ..... i enjoy every single day of it
    2010-07-19 09:19 AM
  11. eyeRobot's Avatar
    Ultrasn0w is supposed to unlock with any bootloader?

    If it's not working with the official carrier I think it's a fair assumption to start considering hardware.
    2010-07-19 09:27 AM
  12. delsoladict's Avatar
    I have the same problem, I have a 3G 4.0.1 with 6.04 bootloader, baseband 05.13.04, ultrasn0w isn't working for me, I put a tmobile sim and I get "No Service", then I use a att and just work fine get all bars.
    2010-07-19 05:53 PM
  13. ozarka's Avatar
    we need an updated ultrasnow . cause mine dont work and my bootloader is like 5.08 wtf
    wtfwtf

    . Really Tempted to buy iphone 4 when unlock is release.... :@
    Common Sense.
    2010-07-19 06:15 PM
  14. Rapala167's Avatar
    we need an updated ultrasnow . cause mine dont work and my bootloader is like 5.08 wtf
    wtfwtf

    . Really Tempted to buy iphone 4 when unlock is release.... :@
    if you've got 5.8 use fuzzyband that will make ultrasn0w work
    I don't suffer from insanity ..... i enjoy every single day of it
    2010-07-20 11:11 AM
  15. ozarka's Avatar
    if you've got 5.8 use fuzzyband that will make ultrasn0w work :
    been there done that. sht dont work and still don't work. i already thought of every possible way. need new update on ultrasnow
    Common Sense.
    2010-07-20 06:45 PM
  16. Rapala167's Avatar
    will i saw somewhere yesterday that an unlock is on its way so i've got to repalce the connector 3 socket on my 3G :/ as i destroyed it opening the phone but i've got bootloader 6.04
    I don't suffer from insanity ..... i enjoy every single day of it
    2010-07-21 10:07 AM
LINK TO POST COPIED TO CLIPBOARD