1. killeryoshi's Avatar
    I have a iPhone 3g jailbroken and unlocked on 4.0 and using Tmobile as my carrier. i couldnt find any information on why i cant send or receive pictures.If there is a thread to my question just link it please but if there isnt, is there anyway to fix this?


    If i cant recieve MMS im just goin to switch it back to AT&T.
    Also is there any information on how to get the data network to work for tmobile? thank you
    2010-07-26 08:30 PM
  2. eyeRobot's Avatar
    Google unlockit and make sure you've got the correct settings in
    2010-07-26 08:44 PM
  3. andrewn80's Avatar
    Hey Yoshi, I have T-mobile also and I just added the MMS 5 days ago to it. Try this and let me know if it doesn't work although it worked perfectly for me.

    Go to Settings > General > Network > Cellular Data Network
    Input the following:




    APN: wap.voicestream.com
    Username:
    Password:
    MMSC: 216.155.174.84/servlets/mms
    MMS Proxy: 216.155.165.50:8080

    Exit, Reboot, and Done! Then try MMS'ing yourself.


    This information can be found on ifixiphone.blogspot.com. Hope it helps!
    2010-07-26 08:58 PM
  4. killeryoshi's Avatar
    thank you i will let you know results tonight!
    2010-07-26 10:28 PM
  5. RyoRuns's Avatar
    thank you i will let you know results tonight!
    So did it work for you?
    2010-07-27 06:26 AM
  6. ronr179's Avatar
    Add the source: http://beta.leimobile.com/repo/ Install the MMS fix and reboot your iPhone.* You may need to enter your APN after the reboot.
    APN: epc.tmobile.com
    Then reboot
    Last edited by ronr179; 2010-07-27 at 06:38 AM.
    2010-07-27 06:35 AM
  7. andrewn80's Avatar
    So did it work for you?
    I guess he's too busy playing with his MMS
    2010-07-27 07:20 AM
  8. killeryoshi's Avatar
    hahaha actually today is my birthday and i was celebrating early.

    um i put in what you said to earlier, now the camera option showed up but i still cant send or recieve. when i try to send it just gives me the red exclamation mark.
    oh and i need to make a correction, its not my phone, its my bosses so its really important i get it to work. lol .ill try the other things when i see my boss tomorrow.im keep checking in frequently and posting my results.


    question.
    how do i make my phone work faster? it seems when i jailbreak my phone its a tad slower.im constantly cleaning it out and using bossprefs to clear all the cache but its still laggy! its kinda embarrasing when im trying to show someone all the things you can do with jailbreaking but it moves slower than paint dries at times!just a question
    thanks again everyone.
    2010-07-27 08:08 AM
  9. SensesFail99's Avatar
    Im running 4.0 and I did this and it worked perfectly! I typed in the repo, then clicked it and installed the mms fix. After the install it tells u to reboot the device. The phone rebooted and BAM mms works again :-) THANK YOU GUYS!!!!
    2010-07-27 09:48 AM
  10. ronr179's Avatar
    Killeryoshi follow my post I put up earlier I should fix your mms problems
    2010-07-27 11:17 AM
LINK TO POST COPIED TO CLIPBOARD