User Tag List

  1. 6309phone's Avatar
    I know there are many others like me that have a 3GS with new boot ROM, spirit jailbreak + ultrasn0w/ TMobile that are wondering what they need to upgrade to 4.0.1/jailbreak/unlock/tmobile.

    Here's what I did:
    1: Backup your iphone with iTunes. (with tmobile SIM).
    2: Turn phone off, put in old AT&T SIM (this was the original now deactivated SIM).
    3: Turn phone on and upgrade to 4.0.1. Note that iTunes will restore all of your apps/settings.
    4: Phone is activated and now turn on Wifi and go to jailbreakme.com on the phone, slide to jailbreak.
    5: Go into Cydia and upgrade essentials. Now search for ultrasn0w and install.
    6: Put TMobile SIM in phone.
    7: Everything should work on 4.0 except you don't have NETWORK settings panel like you did before.
    8: Goto help.benm.at and there's a tethering selection at the bottom of the page. Select it and install the correct profile (country, carrier). Turn the phone off.
    9: When the phone is back on, you will have your Cellular Data Network page again in the settings->general->Network

    Now you can fiddle with settings again. I'm still getting an error receiving MMS pictures but I had that before on 3.1.3. Here's a thread that might help:

    Picture Messages Not Coming Through - Page 3 - T-Mobile Community

    Good Luck!
    2010-08-03 10:15 AM
  2. shanij92's Avatar
    what about ultrasnow?
    2010-08-04 02:15 AM
  3. 6309phone's Avatar
    Step 5 :-)

    MMS is solved! After trying all sorts of things, THIS WORKS with T-Mobile! (T-Zones) (Add Repo, use Cydia)

    T-Mobile iPhone MMS Settings For iOS 4 | LEI Mobile

    At this point, everything works. Jailbreak, MMS, youtube, unlock, everything.
    Last edited by 6309phone; 2010-08-04 at 08:09 AM. Reason: Automerged Doublepost
    2010-08-04 07:33 AM
  4. shanij92's Avatar
    thanks for making piece of cake.
    2010-08-04 11:00 PM
  5. paaji's Avatar
    I am guessing this will work with 3gs as well.

    Version 3.1.3(7E18)
    Serial no. xx948vxxxxx
    Model: MB716LL

    Modem Firmware: 05.12.01

    Do I need to use custom 4.0.1 firmware or just use itunes to upgrade it.
    Thanks
    2010-08-05 06:25 AM
  6. 6309phone's Avatar
    Just iTunes. Jailbreakme.com just works.
    2010-08-05 10:43 AM
  7. cdeldridge's Avatar
    So I have an Iphone 3G[S] with T-mobile. I updated to 4.0.1, then jailbroke the phone with jailbreakme.com, then I installed ultrasn0w 1.0-1. The device rebooted but it did not unlock the phone. Its still saying SIM locked. I uninstalled and reinstalled it several times, with and without the SIM card in. No luck. Does anyone have a fix for this? Thanks...
    2010-08-06 02:39 AM
  8. 6309phone's Avatar
    Is 0.93 still available? That's what I used. Wait. SIM locked? Maybe you have a passcode on that SIM????
    2010-08-06 10:34 AM
  9. cdeldridge's Avatar
    Is 0.93 still available? That's what I used. Wait. SIM locked? Maybe you have a passcode on that SIM????
    Oh you were totally right. All I had to do was put in my SIM passcode that I use with T-mobile and it worked. Thanks...
    2010-08-06 10:34 PM
  10. 6309phone's Avatar
    Great!!!!!!!!!
    2010-08-07 01:20 AM
  11. dorko76's Avatar
    I'm trying to get my T-Mobile SIM to work in my iPhone 3G and followed all of your steps.

    All I get is: "Searching..." followed shortly after by "No Service"

    I don't know what else to do - seems like I've tried everything.

    Not sure if it matters, but I'm on firmware 5.13.04 and bootloader 6.0.4

    Any help would be much appreciated.
    2010-08-16 05:14 AM
  12. iYeow's Avatar
    Turn off 3G to get service for t-mobile.
    2010-08-16 05:33 AM
  13. dorko76's Avatar
    i've tried turning off 3G -

    thanks, though.
    2010-08-16 05:42 AM
  14. iYeow's Avatar
    Remove your sim and reinstall Ultrasn0w version 1.1.1 to see if you will get service.
    2010-08-16 06:14 AM
  15. dorko76's Avatar
    I just tried it and... nada.
    2010-08-16 08:32 AM
  16. 6309phone's Avatar
    Is it possible something is wrong with the SIM?
    2010-08-16 06:03 PM
  17. dorko76's Avatar
    I thought my SIM card might be the problem, so I went to the T-Mobile store and shelled out $20 for a new one. No change, unfortunately.

    Two odd things I've noticed:

    1. If I go into Settings > Phone, my T-Mobile phone number is properly listed under the entry for "My Number". So the phone is definitely 'reading' the SIM to some extent.

    2. My sister has an iPhone 3GS 16GB on iOS 4.0.1 which I successfully unlocked onto the T-Mobile network (via jailbreak.com and ultrasn0w). When I put my SIM into her phone, everything works fine. When I put her SIM into my phone, there's nothing.

    Ugh...

    Let me know if I can provide any more info on my iPhone 3G that might help unravel this headache.

    Judging from a quick google search, it doesn't seem like I'm the only one experiencing similar issues.

    Thanks again to all.
    2010-08-16 07:45 PM
  18. 6309phone's Avatar
    I just realized you have a 3G instead of 3GS like I have. hmmmm I wonder what the difference is if any?

    Notice how yours does search... then gives up. Maybe all you need to do is have the correct T-Mobile settings? Unfortunately this thread is really long and convoluted, but it might help:


    http://modmyi.com/forums/t-mobile/65...g-3gs-4-a.html

    Another thought is have you checked Craigslist around your area? Some places charge only $5-$25 max for unlock. Might be worth a try and let them worry about the unlock.
    Last edited by 6309phone; 2010-08-17 at 03:53 AM. Reason: Automerged Doublepost
    2010-08-17 03:50 AM
LINK TO POST COPIED TO CLIPBOARD