1. BenjThomas's Avatar
    First post here!

    I recently JB and unlocked my iPhone from ATT and brought it down to Australia to use Telstra(an official iPhone carrier). When I put in the sim under about it still says it's using the ATT 7.0 carrier file. Last night I couldn't get internet or MMS working or anything..and then it somehow downloads the Telstra IPCC. Facetime wasn't working because I used the wrong number when I activated it so I had to do a reset all settings.

    I can't for my life recreate what I did and get my phone to get the carrier information. I've tried connecting to itunes, checking for updates, using that manual install trick for the carrier file and none seem to work, so frustrating. When I reset after installing a Telstra APC it says the carrier is "Not available". Can not seem to find ANYONE else having this issue, help would be MUCH appreciated . My questions:

    1. Where can I find the most updated IPCC?
    2. Is there anyway I can force the iPhone to download the IPCC over the air? (I've heard going to about under settings does this but to no avail)
    3. Has anyone else had similar problems?

    SORRY THAT THIS IS SOOOOO LONG, thank you to everyone who tries reading it. I've also talked to a Telstra rep and they're under the impression that iTunes should download it automatically which is NOT happening. My phone somehow did it itself.

    I just fixed it actually, if anyone has the same problem follow these steps.

    1. Full restore set up as a new phone.
    2. Jailbreak, unlock all with the ORIGINAL sim inside the phone.
    3. Continue to wait until the reboot is done, wait till the waiting for activation message disappears.
    4. Put in your new sim and wait for 10 minutes.
    5. Turn the phone off, let it sit for 5 minutes and then turn it back on.
    6. It should of downloaded the carrier information.
    Last edited by BenjThomas; 2010-08-05 at 01:57 AM. Reason: Automerged Doublepost
    2010-08-05 01:57 AM
  2. mickyg56's Avatar
    Benj!!
    thanks so much for finding the solution to this!
    I was having a very similiar problem with my ATT IP4 on the UK o2 network.
    Did several restores and could get the prompt to download o2 carrier settings but it would not update the phone.

    Anyways after another fresh restore I kept the original Sim in for both the jailbreak and restore before inserting the o2 sim. The carrier settings then automatically updated and now everything works: VV, MMS, 3G and EVEN facetime.

    Cheers matey!
    2010-08-05 04:31 AM
LINK TO POST COPIED TO CLIPBOARD