1. teomabanta's Avatar
    Hey guys

    I just jailbroke an iPhone. Worked like a charm

    Then unlocked using repo666. It downloaded fine and worked. Then I clicked the "REBOOT DEVICE" after it finishes...

    But now the phone is stuck on iPhone reboot logo. It's been 10 minutes now. I already retarded twice, no luck

    Anyone know how to fix?

    2010-08-07 02:18 AM
  2. soulthoughts's Avatar
    Try a hard reset. Hold the home and power button at the same time. As soon as it shuts off, let go. Then hit the power button to turn it on.
    2010-08-07 02:22 AM
  3. teomabanta's Avatar
    Tried that. Also does not work
    2010-08-07 02:25 AM
  4. imvirus's Avatar
    Put it on DFU mode and restore it through iTunes and just re-jailbreak and re-unlock. That's if all else fails.
    2010-08-07 09:21 PM
  5. karl184's Avatar
    I had this problem and I was able to fix it. Enter DFU mode and restore to 4.0.1 (You should know how to do this, google it if you don't). You should be able to restore your iPhone successfully. Next jailbreak it with jailbreakme.com, After, go to Cydia and it will ask you to upgrade some components, upgrade them and it will ask you to restart. Agree with it. Fire up cydia again and make sure that it's no longer asking you to upgrade. Then, download ultrasn0w. Read the instructions and makesure you have the correct firmware on your phone as well as the baseband (4.0.1 or lower and 1.59 for baseband or modem firmware). Install ultrasn0w and let it do its job. Even if it seems finished and gives you the option to restart, look at the SIM logo on the upper left of your phone. You should wait until it no longer shows "Searching" and instead your operator logo with bars on. Once you see it, click restart and it should work.
    2010-08-18 02:57 AM