User Tag List

  1. elalepanpan's Avatar
    I just got my new iphone 4 (IOS 4.0.1), coming with AT&T activation card (no contract).

    I jailbroke it with JailbreakMe. It works like a charm: the tools such as sbsetting, openssh/openssl work well.

    I then installed ultrasn0w 1.1-1 from its official source ( Installation goes smoothly without any error/warning message, and I rebooted the system at the end of installation according to its instruction.

    However, after replacing the AT&T card with my own non-AT&T SIM card and rebooting the iphone 4, it keeps telling me "Different SIM detected, please connect to iTunes" and only Emergence Call is available.

    This seems that the unlock just failed. Note that, at this time, my carrier's name with full-signal bar appears on the status bar of the lock screen. When I pull out my SIM card, I can enter the system without any SIM in the phone.

    I removed and installed the Ultrasn0w again for several times, all failed. I then jailbroke the iphone for several times as well, but all with the same results (jailbreak works, unlock fails).

    I tried to restore the firmware for another fresh jailbreak, but failed as well, since as we know, Apple stops signing iOS 4.0.1, and this is a new iphone, I didn't have chance to backup the SHSH blob.

    Any clues or suggestions are highly appreciated!


    BTW, I can ssh to the iphone from my computer even the iphone is in the "Emergence Call" interface and my mobile carrier's signal seems rather good. I wonder if there's any way to let the iphone jump out of the sim-lock stage (maybe using some (cydia) tool).
    Last edited by elalepanpan; 2010-08-29 at 06:29 AM. Reason: Automerged Doublepost
    2010-08-29 06:12 AM
  2. dallax's Avatar
    after installing ultrasn0w

    I had the same problem

    Put back the phonebook /at&t inactive SIM and install
    the Hacktivation patch at
    you can find all the instructions at this address

    After installing the Hactivation Patch
    then retry using your other sim.
    It worked for me
    Last edited by dallax; 2010-08-29 at 08:17 AM.
    2010-08-29 07:57 AM
  3. elalepanpan's Avatar
    This works! Thank you very much!
    2010-08-30 05:07 AM