1. scoobydrew813's Avatar
    I have an unlocked iphone 4 running on T-mobile. I have gone through 3 iPhone 4s and all of them have had the problem I'm about to describe, so it must be a problem with something I'm doing.

    I activate my no contract phone thru iTunes with the blank ATT so that I can jailbreak. NOTE the "Waiting for Activation this may take some time" screen still appears and only dissapears once I unlock and get T-Mobile service. After restoring from backup, I jailbreak with jailbreakme. Next, I install ultrasn0w and insert my T-Mobile (cut with Microsim Cutter) sim. For the first 10-15 turnons of the device, the unlock is working just fine. After about 10-15 turnons, I will turn my iPhone on and instead of having T-Mobile signal, I either get "No Service", "Invalid SIM", or the most common one: one bar with no carrier name with which I cannot use any cellular function. I have researched this problem for hours and found people with the same problem but nobodys post has any responses. I AM DESPERATE ANY HELP WOULD BE GREAT AND A LIFE SAVER!!! BTW i have iPhone 4 16gb with 4.0.1.
    2010-09-22 08:24 PM
  2. i.Annie's Avatar
    The problem is probably you restoring from back up. You'll want to set up as new. Everytime you restore from back up, you're just bringing back the problem.
    2010-09-22 08:27 PM
  3. nebo1ss's Avatar
    I had both of those exact same symptoms a month or so ago and just restored, set up as new as suggested above by Annie and JB and Unlocked again and have no problems since with TMobile. I thought at the time that my problem was related to some patches I made for Internet Tethering but I have seen so many with the same problem that I think it is a quirk with jailbreakme.com.
    2010-09-23 02:58 PM
  4. scoobydrew813's Avatar
    I have tried all of this. Is there any chance that syncing with iTUNES could ruin it. I have been jailbreaking for a while so any system changes needed to be made to jailbreak a previous version might have messed this up.
    2010-10-13 12:18 PM
  5. i.Annie's Avatar
    You know what, it's weird because i just did 2 of my iP4's and I had to do them differently. The first one, I restored to 4.1, jb with limera1n, activate in iTunes, then restored from back up. The second one when I tried that I didn't have any AT&T service. So I restored to 4.1, activated in iTunes, restored from back up, then jb with limera1n.
    2010-10-13 03:33 PM
  6. scoobydrew813's Avatar
    I have restored as new and it seems to work fine until I sync it with iTunes. Also, I don't use a data plan so I dont have data settings set up. Does this help?
    2010-10-13 06:44 PM
  7. IDejaVu's Avatar
    i have the same problem and pretty desperate as well. I hope there is a fix for this.
    2010-10-13 08:47 PM
  8. scoobydrew813's Avatar
    I feel your pain. SOMEONE HELP!!!
    2010-10-13 09:07 PM
LINK TO POST COPIED TO CLIPBOARD