1. mac4life's Avatar
    I just joined this forum and I need your help! I am currently working in Spain and bought a Vodafone micro sim. I have an iphone 4 with version 4.0.1 (8A306) and FW 01.59.00. I want to unlock it so I can use my Vodafone sim here. I used jailbreakme to jailbreak and had no problems. After cydia, I installed ultrasn0w 1.1-1 to unlock. However, when I insert my Vodafone sim, it searches then says "no service." Orange, Movistar, and Vodafone are all listed in the carrier settings, but I can't pick them to get service from any of them. I've been trying for a couple of weeks now reading a lot of forums and have tried a lot of tips like hard reboots, 3G off, airplane mode off and on, resetting all or network settings, reinstalling ultrasn0w, etc. None of this is working for me. A friend here has a 3GS with 4.0.1 and used jailbreakme and ultrasn0w and had no problems with his vodafone sim card. I wanted to try his, but it's not a micro. I still have my AT&T sim and that still works fine after the unlock, but "no service" with the Vodafone. Could this be an issue because it's an iphone 4? Seems like the 3GS had no problems. Any advice? This is very frustrating!!
    2010-10-06 09:38 PM
  2. Rinnycoop121's Avatar
    Most likly you need a new sim from Vodafone

    Thats all i can come up with right now.

    If you cut your sim your self maybe you damaged the sim during the cut.

    if you know anyone else who is running an iphone 4 on Vodafone you can try there sim if it is allready cut and see if it works.

    If it does then you need to replace your sim.
    2010-10-06 10:28 PM
  3. mac4life's Avatar
    I didn't have to cut it. Vodafone also sells micro sims.
    2010-10-06 11:32 PM
  4. Rinnycoop121's Avatar
    then i don;t know what to tell you
    2010-10-07 06:15 AM
  5. i.Annie's Avatar
    The best I can say is get a micro SIM adapter to try your SIM on your friend's phone. If your friend's phone doesn't take your SIM, then it's your SIM. if it does take it, it must be your phone.

    Sometimes the unlock doesn't work cuz maybe the jb wasn't properly installed. If you have your SHSHs, restore and jb again. If you don't have your SHSHs, well, all you can do is remove Ultrasn0w and reinstall or try installing the ultrasn0w toggle for SBSettings and toggle it on and off.
    2010-10-07 06:45 AM
  6. mac4life's Avatar
    I just recently dl'd tinyumbrella a couple of weeks ago. It saved my SHSH for 4.1, but I've been hesitant to upgrade bc I think more people are more successful unlocking 4.0.1. I will try the SBSettings and look for a sim adapter or even buy a cheap phone that takes the micro if I have to. Do you think I should go to 4.1 and try to unlock?
    2010-10-07 09:15 AM
  7. iYeow's Avatar
    There is no jailbreak and unlock at 4.1. Don't do any foolish stuff on Cydia, if it crashes, you are forced to go to 4.1
    2010-10-07 11:41 AM
  8. mac4life's Avatar
    I just read the Greenpois0n might be released in the next few days. Maybe if I can't get 4.0.1 to unlock, I'll try to use tinyumbrella to go to 4.1, preserving my 1.59.00 baseband, then jb with Greenpois0n and try ultrasn0w again. What do you think?
    2010-10-07 11:49 PM
  9. i.Annie's Avatar
    If you don't have your SHSHs for 4.0.1 or 4.0, then what you just said is your only option to jb and unlock
    2010-10-08 12:01 AM
  10. mac4life's Avatar
    Just used TU and restored to 4.1 with 1.59.00 FW. Used Limera1n to jb and installed cydia and ultrasn0w. Still getting the same thing, "no service."
    2010-10-11 02:10 AM
  11. iYeow's Avatar
    Just used TU and restored to 4.1 with 1.59.00 FW. Used Limera1n to jb and installed cydia and ultrasn0w. Still getting the same thing, "no service."
    After you have restored to 4.1, put your Atnt micro sim in to activate and then use Limera1n.
    2010-10-11 07:29 AM
  12. maurosch's Avatar
    My advice is to put tour vodafone micro sim in the iPhone and after you install and ultrasnow asks you to reboot , you must be connected to iTunes so the phone can be activated. That's what I did and it worked like a charmed!!!!
    Let me know how it works out for you !!!!
    2010-10-11 02:28 PM
  13. mac4life's Avatar
    I had my AT&T sim in after the restore and it said my phone is activated. It works fine with AT&T. I'm thinking I'm going to go today and buy a regular Vodafone sim, put it in my friends 3GS to make sure everything is working with the sim, then cutting it down and trying in my iP4. I don't know if it's an issue with my sim or the unlock isn't working. I would like to try the micro I have now in another phone, but it's cheaper to buy another sim. The guy told me it cost around 1800 euros for the iphone 4 without a contract here. LOL And the iphone 4 is the only phone he sells at the store that takes the micro.
    2010-10-11 05:44 PM
  14. mac4life's Avatar
    After weeks of restoring, JB'ing, and unlocking, I began to think that the micro sim I bought from Vodafone was no good. I made an adapter (cut out of my hotel room key) so I could put my micro sim into other peoples phones. It had no service. I took it up to Vodafone and they told me it was good and it's showing as active. I bought a regular sized sim, put it in my friend's unlocked 3GS and it was working. I then cut it down to micro, threw it in my iphone 4 and it worked. I'm assuming my phone was unlocked the whole time, but I've waisted hours of my life trying to get it to work with the micro. It's weird, I would have thought that just buying a true micro would have worked before a cut down sim. Anyways, I don't care. I'm a happy camper. Thanks everybody for your input...
    2010-10-18 07:59 PM
LINK TO POST COPIED TO CLIPBOARD