1. scoobydrew813's Avatar
    This is a problem similar to one I have had before, but I can describe this better. I have an unlocked iPhone running on tmobile and it was working fine for a day, but after I hooked it up to iTunes, it now periodically gives me a "one bar" without a carrier or give me searching... for a long time and then "no service" in a place where I know I have service, whenever I turn it on. when this happens it has no carrier options under settings. This only happens about 1/3 of the time I turn my phone on, so there must be some way to fix it. I'm thinking that there could have been something that itunes did when I synced it, or it just happened. I have tried everything I can think of, and I am desperate, so please help me I want to be able to use my unlocked iPhone!!!
    2010-10-13 12:36 PM
  2. eyeRobot's Avatar
    Have you restored it and tried setting it up as a new phone?

    (obviously you'll need to preserve your baseband...)
    2010-10-13 12:58 PM
  3. scoobydrew813's Avatar
    Yes, and it seems that it works fine until I sync it to itunes
    2010-10-13 06:42 PM
  4. acer0628's Avatar
    ii have just jailbroken my iphone 3gs and i ahve no network coverage where i know i shoul dbe covered i have pulled the sim card reset the network and still nothing so what the hell is going on i need a quick fix can someone help
    2010-10-18 04:53 PM
  5. zanetran's Avatar
    I have the same problem I preserved my baseband when upgrading to 4.1. I then used Ultrasnow for the unlock but now I'm getting the No service ~ 1 bar no t-mobile problem. This only occurred after I powered off the phone.
    2010-10-18 10:39 PM
LINK TO POST COPIED TO CLIPBOARD