1. scoobydrew813's Avatar
    I have an unlocked iPhone on T-Mobile that had been set up as new. Sometime, when I turn it on it works fine, but about half the time when I turn it on, I get Sim Failure...Invalid Sim. Please help. Is it something I need to fix via ssh or a patch? Please don't suggest restoring because I have done this at least 20 times with the same result.

    Last edited by scoobydrew813; 2010-10-16 at 12:09 AM. Reason: Automerged Doublepost
    2010-10-16 12:09 AM
  2. iYeow's Avatar
    Install lockdown patch from the added repo of Cydia : cydia.pushfix.info
    Reboot and see if it solves your problem.
    2010-10-16 06:23 AM
  3. Waleed786's Avatar
    What kind of iPhone is it?
    2010-10-16 06:40 AM
  4. scoobydrew813's Avatar
    2010-10-17 04:16 AM
  5. Waleed786's Avatar
    Ur SIM is cut incorrectly. I told u before didn't I? Did u try with a new SIM? Or try that SIM in another iPhone 4?
    2010-10-17 04:20 AM
  6. randerson79's Avatar
    I had the same problem. Try resetting network settings. That worked on 1 phone. The other one I ejected the sim over and over. It worked after the 6th try.

    Just a thought.
    2010-10-17 05:53 AM
  7. Ejb5oh's Avatar
    BUMP!! Looking for this fix too.
    2010-10-19 03:11 AM
  8. scoobydrew813's Avatar
    There is no way that the sim ic cut incorrectly. I purchased a $20 sim cutter that cuts out your sim into a microsim perfectly. It fits exactly into the sim tray and I have tested it and it works fine on other devices that use microsim.
    2010-10-19 03:32 AM
  9. Flid's Avatar
    I've had problems with "Invalid Sim" "Sim Card Not Inserted" "No Sim" "Fixed Dialling Active" pop-ups (every 4 hours or so) ever since updating my iPhone 3G to 4.0.1, Jailbreaking with Jailbreakme.com and using Ultrasn0w.

    Initially, I started removing and re-inserting the SIM. This fixed it temporarily for a few hours.
    Then using SBSettings/Power/Reboot ('cos I couldn't be bothered carrying around a pin in my wallet). This worked, again, temporarily for a few hours.
    Then I tried the Ultrasn0w SB Settings toggle. This didn't seem to help.
    Then I discovered that toggling the "Phone" Off>On via SBSettings was the quickest temporary fix.

    Based on a recommendation above, I went to reset my phone's carrier settings, but couldn't find them anywhere (they definitely used to be in there). I'm guessing they've simplified the user entry options in iOS4. I did reset "Network Settings" to factory default. No idea if this effected the phone/carrier settings, but it did reset all my WiFi passwords. No problems so far, but... we'll see.
    2010-10-19 01:00 PM
  10. Flid's Avatar
    Nope. No joy. Still failing to be stable.
    Have tried re-installing Ultrasn0w. Also no joy.
    Fingers crossed for iOS4.1 & Pwnage/Sn0wbreeze.
    2010-10-20 03:39 PM
  11. scoobydrew813's Avatar
    I havent confirmed but you guys can try this:

    How To Fix Different SIM Detected on Emergency Mode After Jailbreaking iPhone 4/3GS/3G | TheTechJournal.com

    Tell me if it works for u. Also, might using the new pwnage tool to restore do anything?
    2010-10-21 01:47 PM
  12. bmita's Avatar
    iPhone 4 32GB iOS 4.1, baseband 1.59 preserved with umbrella method.
    First time jailbreaked with limera1n and unlocked with ultrasn0w. Works fine for a week. Now lost service (NO SERVICE).

    Restored and jailbreaked with limera1n or greenpois0n (several times) and unlocked with ultrasn0w.
    Now I have Invalid SIM message...
    After reseting Network Settings I have No Service message...

    I tested two different micro SIM's with no luck...

    In General/Carrier I can see the three carriers and when I select my carrier (VIVA Nuevatel) I have the following message:
    Restricted Network
    You selected cellular network is restricted. You can choose a diferent network in Settings.

    Perhaps there is an incompatibility between ultrasn0w and the BB 1.59 on iOS 4.1 specifically in cases like this.
    Or simply BB 1.59 and iOS 4.1 are incompatible in certain cases.
    Or AT&T SIM has some different to my adapted "microSIM"

    I don't know... I would love to know...
    I would be sure to wait for the new version of ultrasnow.
    It's really frustrating not being able to use phone.

    Anyone can help us please????
    Last edited by bmita; 2010-10-21 at 07:10 PM.
    2010-10-21 07:05 PM
  13. scoobydrew813's Avatar
    did the solution I posted work for anyone?
    2010-10-23 04:15 PM
  14. bmita's Avatar
    did the solution I posted work for anyone?
    Hacktivation patch does not work with iOS 4.1
    2010-10-23 05:51 PM
  15. scoobydrew813's Avatar
    Well, this seemed to fix my problem on ios 4.1 ill post again if the problem comes back
    2010-10-23 06:22 PM
  16. shinya1104's Avatar
    Well, this seemed to fix my problem on ios 4.1 ill post again if the problem comes back
    If you have shah 4.0,you back to iPhone4+ iOS4.0+jailbreakme+ultrasnow+pdf patch.

    That's good working.

    Or So wait for iPhone4+iOS4.2&unlock in future.
    2010-10-24 06:20 PM
  17. Flid's Avatar
    As mentioned in my previous post, I have been continuing to have endless "Invalid SIM" "SIM Card Not Installed" "No Sim" "No Service" problems, recurring every hour or two. Using SBSetting Phone toggle has been the quickest way to temporarily resolve, but nothing has been able to make it stable.... until....

    I stumbled across another thread yesterday (about iPhone4 users losing service in a similar manner). The mentioned suggestion was to try the Hacktivation Lockdown Patch.

    So... I figured it would be worth a try.

    So... Cydia... added cydia.pushfix.info and then noticed the Carrier Reset Fix in the repo. Did a quick google, and noticed someone else mentioning that it fixed their problems.

    Gave it a try. Installed. Pulled SIM card out. Re-inserted.

    16 hours have now passed without a single SIM problem!!!
    This is the longest amount of time I've had with a stable SIM since upgrading to iOS4.

    It might be worth a try for others.
    I'll update if there is any change.

    (ps. I didn't install the Hacktivation patch - just the Carrier Reset Fix).

    iPhone3G (8B117) - MB500B/A
    Baseband: 05.13.04-5.9_M3S2
    Jailbroken to 4.1 with preserved baseband via PwnageTool + Ultrsn0w unlock.
    Last edited by Flid; 2010-11-18 at 01:55 PM. Reason: misleading typo + info on my phone specifics
    2010-11-18 01:24 PM
  18. Flid's Avatar
    Just for the record... the above "Carrier Reset Fix" has continued to be stable and have not had any "Invalid SIM"/"No Sim" messages for the last few weeks.

    I've now given my old iPhone3G to my wife... and all seems well. Still getting occasional crashes, but SIM and network connections are staying happy (as is my wife... who was scared to accept the old iPhone after all the troubles I've had).

    I've just seen that there is a NEW Ultrasn0w out, along with a baseband upgrade (via iPad FW?!) that is meant to work on the iPhone3G and 4.2.1

    I'll be keeping an eye on this, but if anyone tries it (and has been having similar problems with their SIM)... please post the outcome / success comments here.

    2010-11-29 12:30 AM
  19. R.STUNNA's Avatar
    Ur SIM is cut incorrectly. I told u before didn't I? Did u try with a new SIM? Or try that SIM in another iPhone 4?

    I had this same issue with an iPhone 4... until I just went out and got a new sim and my own sim cutter and was very careful in cutting it. Havent had an issue since.
    2011-01-14 03:45 AM