1. mattybobatty's Avatar
    Hey forum goers,
    I import AT&T American 3G iPhones into New Zealand where I hackivate and unlock them before selling on to family and friends for significantly less than the local iPhone market price.

    Recently I have been having issues with GPS signal once the phones have been hackivated through redsn0w. I've had the problem on IOS 3.1.2 - 4.0.2.

    Wifi-triangulation works just fine, but GPS has no signal.
    The reason I believe this is due to the hackivation is because some of the iPhones I receive have already been activated via SIM and soft jailbroken- and the GPS works.

    I have fixed push notifications and tried restoring firmware etc but still no solution. I really doubt that the issue is with the wireless chipset and hardware based as it has happened on a number of my phones.

    Anyone else had GPS issues with hackivated iPhones?
    Any ideas?
    2010-11-15 02:01 AM
  2. Simon's Avatar
    Ya Hacktivating can cause a few issues. if possible you should try to get ahold of a ATT sim so you can use that to activate the phones. Everything 'should' work fine doing it that way.
    2010-11-15 02:36 AM
  3. mattybobatty's Avatar
    Thanks for the fast reply x98car.
    The strange thing about it is that there are very few other people having the same GPS issue when jailbreaking through redsn0w- yet I have had problems of a number of iPhones. Plus, after restoring/downgrading/upgrading firmware then rejailbreaking, the GPS issue still remains.

    Getting an At&T American SIM in NZ could be a bit of an issue but might be worth a shot.
    2010-11-15 12:44 PM
  4. eyeRobot's Avatar
    I had problems with my GPS on a 3GS, I just swapped out the wifi/gps flex and it's working fine now. Took me about 2hrs due to my sausage fingers and gammy eyes!
    2010-11-15 01:00 PM
LINK TO POST COPIED TO CLIPBOARD