1. Simon's Avatar
    Is that a question? If so check the first post near the bottom.
    2010-12-01 03:36 AM
  2. ArcticPrince's Avatar
    Advice Please...I have a jailbroken/unlocked iphone 4 running on 4.01 and 1.59.00. Everything works just fine EXCEPT I can not change my APN so that I can use data. I have tried the APN changers from Unlockit.nz and benm.at but either I am doing it wrong (high degree of probablilty!) or it just doens't work for me.

    Can I upgrade to 4.1 and get the ability to set my APN manually?

    2010-12-02 05:43 AM
  3. Simon's Avatar
    Not too sure. That setting being there can be carrier dependant. I am sure there is a way to make it show though. Maybe a tweak in cydia.
    2010-12-02 05:45 AM
  4. ArcticPrince's Avatar
    As I understand it, Apple hid the APN settings at AT&T's request to make it harder for people to switch to T-mobile, etc. I also understand that iphones designed for other carriers do not hide the APN settings.
    2010-12-02 06:11 AM
  5. Mes's Avatar
    If this is true (and I doubt it), then it just occurred on 4.2.1. The T-Mobile carrier bundles by SpookeyET do not show APN, but can easily be changed. His work is good, but I won't use because they are hidden.
    2010-12-02 06:20 AM
  6. Simon's Avatar
    I'm not too fmailiar with what is required for t-mobile. But I do know where I live on the 3 carriers here I am able to edit APN regardless of if it is a factory unlocked or software unlocked iPhone (no official carrier here).
    2010-12-02 12:54 PM
  7. ArcticPrince's Avatar
    I was just using T-mobile as an example, I am actually in the Philippines trying to use my 4 on the Smart network. I have a 3 that works just fine, but want to use my 4 and sell the 3. On the iphone 4 purchased through AT&T, the ability to just enter APN settings is not available.
    2010-12-02 02:14 PM
  8. Simon's Avatar
    2010-12-02 02:20 PM
  9. ArcticPrince's Avatar
    Its been awhile, but I think I used Limerain to jailbreak.
    2010-12-02 02:48 PM
  10. Simon's Avatar
    It may be that then, like I said not too sure when it comes to this issue.
    2010-12-02 02:49 PM
  11. Mes's Avatar
    Check the info.plist of y.o.u.r carrier bundle (/System/Library/Carrier Bundles/xxxx.bundle/). This little piece of code should be inside:

    2010-12-03 10:12 AM
  12. ArcticPrince's Avatar
    The carrier that I am trying to add is Smart telecommunications in the Philippines. They are not on the list. I think that Globe supports the iPhone and Smart has the blackberries. Some sort of deal they worked out so as to not compete for the high dollar corp accounts.

    However, thanks for that info..didnt know that was there...
    2010-12-03 11:26 AM
  13. Mes's Avatar
    ^Artic ....

    If you have cell service (phone/SMS), then you are using a carrier bundle. Probably the unknown.bundle?!

    I don't believe the phone will work without using some bundle.

    In /private/var/mobile/Library there shoud be two links: Carrier.bundle and Operator.bundle. These two links point to the actual carrier bundle the phone is currently using.
    2010-12-03 11:35 AM
  14. ArcticPrince's Avatar
    Yes, they are both there, but I can not figure out where they are pointing. They are just shortcuts to the folder of the same name, and within that folder I can not determine which of the bundles is being used. If it helps any, I am using diskaid to access the root.

    On my iphone 3, I just needed to enter "internet" into the apn with no passwords or anything.

    I really appreciate your trying to help me, if nothing else I am learning a lot about the file system...lol
    2010-12-03 02:30 PM
  15. Mes's Avatar
    When you click
    on Carrier.bundle or Operator.bundle you will be automatically redirected to the real carrier bundle. That directory will contain several files, info.plist, carrier.plist, Default_xxxxxx.png, FSO_xxxxxx.png and maybe others. xxxxxx is the name of the carrier bundle. It should also be the same as the now parent directory.

    The info.plist should have the EDGEEditing key mentioned in a prior post.
    2010-12-03 03:05 PM
  16. ArcticPrince's Avatar
    When I click on the shortcut Carrier bundle.bundle or Operator bundle.bundle it expands into 100 or so shortcuts named Default_Carrier_***.png. There are at least 100 of these all named by different carriers in different countries. None of them are highlighted or standout in any way. I have no way of determining which of those shortcuts are being accessed.
    Last edited by ArcticPrince; 2010-12-03 at 03:20 PM.
    2010-12-03 03:17 PM
  17. akash86's Avatar
    it is. check my link or the main post on this thread
    2010-12-04 03:01 AM
  18. ArcticPrince's Avatar
    Sorry, but don't follow you on this post. What do you mean "it is. check my link"?
    2010-12-04 04:14 AM
  19. Mes's Avatar

    There should be only 1 info.plist file, yes?

    Look inside for the EDGEEditing key (from a prior post). If it's not there, add it and you should have access to APN editing.

    Oops, the file name is: carrier.plist (not info)
    Last edited by Mes; 2010-12-04 at 04:38 AM. Reason: Automerged Doublepost
    2010-12-04 04:38 AM
  20. Bo Troxell's Avatar
    ^ This works, has used that method on several phones.
    2010-12-04 05:02 AM
1,134 ... 234561454 ...