User Tag List

  1. ArcticPrince's Avatar
    I am NOT being automatically redirected to the real carrier bundle,at least not that I can determine. All that happens when I click on carrier.bundle or operator.bundle is a list of ALL the carriers opens up, but none of them are highlighted or in any way indicate which of the bundles is being used.
    2010-12-04 04:36 AM
  2. Mes's Avatar
    ^Artic ...

    I will try to explain. Apple provides many carrier bundles, each in separate folders (aka bundles) PLUS one large bundle called unknown. Inside unknown is carrier.plist, info.plist and many Default/FSO_xxxx.png files.

    The only file you care about is carrier.plist. When you click on /private/var/Library/Operator.bundle, you are redirected to the right place. Look inside carrier.plist for the EDGEEditing key.
    2010-12-04 08:09 AM
  3. ArcticPrince's Avatar
    I finally found it thanks, but this is allready there:

    AllowEDGEEditingYsignature

    and I still do not have APN. Any more suggestions? I do appreciate your patience..
    2010-12-04 01:07 PM
  4. Mes's Avatar
    The line after 'Allow EDGEEditing' can be false or true. Is you're set to true?
    2010-12-04 01:20 PM
  5. ArcticPrince's Avatar
    This is what I see when I open in notepad:

    [ _ShowCallForwarding_StatusBarImagesTapnsSMMS_ ASCIIFileNameRequired[CarrierName_AllowEDGEEditingYsignature_ShowCal lForwarded^ShowDialAssist\SupportsNITZ]

    Is this the correct reference, and if so how should I edit it? You have me and 3 other guys hoping you can help solve this dilema..

    Thanks again
    2010-12-05 01:10 AM
  6. Mes's Avatar
    Good morning Artic ....

    (I just woke up to my favorite poster )

    You can not properly view or edit carrier.plist with notepad. A .plist (property list) file requires a plist viewer/editor on Windows.

    Google search 'plist edit windows', find and select "pledit", download & install on computer.

    Then copy carrier.plist to your computer and open it with pledit. Look again for the key and true or false immediately after.
    2010-12-05 02:17 AM
  7. ArcticPrince's Avatar
    When I opened it with a plist editor it is allready set to true:

    <key>AllowEDGEEditing</key>
    <true/>

    Now what?

    (Visualize my bloody forehead from constantly pounding on my desk)
    2010-12-05 05:13 AM
  8. Mes's Avatar
    Check these as well:

    <key>AllowEDGEEditing</key>
    *<true/>
    *<key>AllowMMSCEditing</key>
    <true/>
    <key>AllowMMSEditing</key>
    <true/>

    With one or
    more of these keys you should see a Cellular Data Network tab from Settings/General/Network

    Clicking the tab should bring up a screen to add/edit the APN.
    2010-12-05 05:53 AM
  9. ArcticPrince's Avatar
    This is what I have now, but still no APN availability. All I have is Cellular Data ON or Off.

    <key>AllowEDGEEditing</key>
    <true/>
    <key>AllowMMSCEditing</key>
    <true/>
    <key>AllowMMSEditing</key>
    <true/>
    2010-12-05 07:53 AM
  10. Mes's Avatar
    Have you installed any other apps from Cydia to get APN to show?
    2010-12-05 01:56 PM
  11. ArcticPrince's Avatar
    I don't know of any such apps. I did try the APN changers from Unlockit.nz and benm.at but did not have any luck with them. They appear to be scripts to input the APN info, not show the APN module.
    2010-12-05 02:09 PM
  12. Mes's Avatar
    Artic...

    I don't like to say crapware, because every app has a purpose. However some apps claim to work but acutally help only a few. The others often have more problems and may never find a fix. I understand it's difficult to know what will work.

    The info I provided works. Why not for you ... I must assume it's a conflict with something that didn't work before.

    Bottom line, there is little more I can do to help. You must either remove everthing that didn't work, or better yet, start over a fresh un-modified system.

    Apple does not block APN editing on a standard phone. If unavailable it comes from something installed after. Most don't need to edit anything
    2010-12-05 04:18 PM
  13. ArcticPrince's Avatar
    I appreciate your trying to help, thanks. I now have another problem, lol I plugged my phone in to my puter this am and got this message:

    "The SIM card inserted in this iPhone does not appear to be supported. Only compatible sim cards from a supported Carrier may be used to activate iphone."

    I have had this same sim card in this phone for about 3 months and have never had a problem before. I really hate apple and how they try to manipulate everyone!!


    I just restored to the old plist and my sim card error message went away...Stranger and stranger....
    Last edited by ArcticPrince; 2010-12-05 at 10:53 PM.
    2010-12-05 10:47 PM
  14. Mes's Avatar
    Glad it's working again. Which 'old' plist did you restore? Because you said the additions were already there. Did you change anything?

    Artic... I suggest you restore to 4.0.1, jailbreak, and load Ultrasnow. Add nothing else. Then edit APN. It should work. Then from iTunes, set up as new phone and add Apple & Cydia apps.

    You need SHSH blobs to reload 4.0.1
    2010-12-06 01:44 AM
  15. ArcticPrince's Avatar
    When I started modifing, I just renamed the original as plist.old, and then worked with a copy of the original. That way I always had something to reload in case I mucked everything up.

    I have the shsh blobs, but don't really have the time at the moment. Perhaps this coming weekend I will give the restore a go...

    Thanks again for all your help.
    2010-12-06 04:08 AM
  16. babes's Avatar
    I have unlocked one 3gs using ultrasn0w by changing the baseband but when I am trying to do a different one I keep getting a msg saying that redsn0w has stopped working what can i do?
    2010-12-06 05:49 AM
  17. Simon's Avatar
    Are you running redsnow in windows xp sp 2 compatibility mode?
    2010-12-06 12:39 PM
  18. babes's Avatar
    Ok I got everything done on my with XP but when i installed ultrasn0w it is now stuck on apple logo. It is on 4.2 with the ipad baseband. What can I do
    2010-12-07 04:27 AM
  19. Mes's Avatar
    Old or new bootrom? If new, it's a tethered boot. Need redsnow to 'just boot terhered'.
    2010-12-07 04:56 AM
  20. babes's Avatar
    I did the just tethererd thing and then i installed ultrasnow and thats when it went to the apple logo and now it is the itunes logo
    2010-12-07 05:00 AM
1,134 ... 345671555 ...
LINK TO POST COPIED TO CLIPBOARD