User Tag List

  1. herring14's Avatar
    Hi,

    I need to unlock a 3GS on 4.1, (8B117), 05.14.02

    I have jailbroken and unlocked other iphones in the past but i was just hoping that somebody could confirm firstly IF it can be done for this model?

    If so, please can somebody point me to a reliable idiots guide to doing so as i am a little rusty on the subject....

    Thanks in advance
    2010-12-07 02:06 PM
  2. Simon's Avatar
    The only way to unlock that would be to use the new ipad baseband update method. It has a few drawbacks so you may want to read about it first: Dev-Team Blog
    2010-12-07 02:09 PM
  3. herring14's Avatar
    Ok, i am quite sure that i wish to proceed but still not entirely sure how i do so...

    Do i update to 4.2.1? Or do i remain on 4.1?

    I have what looks like an idiots guide: iClarified - iPhone - How to Jailbreak and Unlock Your iPhone 3G Using RedSn0w (Windows) [4.2.1]

    BUT it doesnt state it works for 3GS, can you confirm this for me please?
    2010-12-07 02:27 PM
  4. Simon's Avatar
    Yes this works for 3GS. You can use the basic steps in that guide but just do it for 4.1 and 3GS. You can get a 4.1 firmware from the downloads section at the top of the page. You dont want to go to 4.2.1 as that may be a tethered jailbreak for you so 4.1 is better. Just download the 4.1 firmware for 3GS, point redsnow to it then just choose the ipad baseband box and install cydia (if you dont already have cydia on there).
    2010-12-07 02:33 PM
  5. herring14's Avatar
    I have tried doing this but when trying to put the phone in to DFU mode, the screen cuts off very early when holding both the power button and the home button. I have trieda few times but to no avail, is this a common problem?
    2010-12-07 05:03 PM
  6. Simon's Avatar
    Try running redsnow in windows xp sp2 compatibility mode
    2010-12-07 05:23 PM
  7. herring14's Avatar
    I have managed to jailbreak the handset BUT when rebooting it gets stuck on the apple logo with the spinning weel.... the wheel is not moving.

    Am i in trouble?
    2010-12-09 01:54 PM
  8. Simon's Avatar
    After the initial jailbreak or after something else?
    2010-12-09 02:01 PM
  9. herring14's Avatar
    After the Jailbreak... I had left the phone for 5 mins to do it's thing and came back to it stuck on the apple logo with a frozen spinning wheel. I have since tried hard resetting a few times and the wheel starts spinning for a minute or so before stopping and freezing!

    Any advice?
    2010-12-09 02:08 PM
  10. Simon's Avatar
    Sounds like you may need a restore. What firmware did you point redsnow to?
    2010-12-09 02:09 PM
  11. herring14's Avatar
    iphone2,1_4.1_8B117_Restore

    I am able to restore and update via itunes but im guessing i shouldnt update if i want to unlock it?

    EDIT:

    I tried to restore and update but it failed. Getting a little worried now....
    Last edited by herring14; 2010-12-09 at 03:13 PM.
    2010-12-09 02:14 PM
  12. Simon's Avatar
    Updating to 4.2.1 won't affect your ability to unlock. It will be a tethered jailbreak if you have a new bootrom 3GS though.
    2010-12-09 03:12 PM
  13. herring14's Avatar
    How can i update the firmware? I recall something about holding sh ift and restore in iTunes!?!

    Sorry for the constant qustions but im in a bit of a situation
    2010-12-09 03:16 PM
  14. Simon's Avatar
    You should download idetector:iH8sn0w.com | Jailbreak your iPod touches and iPhones

    Find out what bootrom you have before you update.
    2010-12-09 03:27 PM
  15. herring14's Avatar
    It tells me i have the new bootroom..... What do i do next?

    I have tried to restore 4.1 and 4.2.1 but neither willl work.
    2010-12-09 03:37 PM
  16. Simon's Avatar
    That means you will want to stay on 4.1 if possible. What errors are you getting?

    Do you know what SHSH you have?
    Last edited by Simon; 2010-12-09 at 05:13 PM. Reason: Automerged Doublepost
    2010-12-09 05:13 PM
  17. herring14's Avatar
    I know nothing about SHSH!?! The phone now seems to be stuck in recovery mode and i am getting a 1015 error from itunes.

    Tried recboot but it seems to have messed up my laptop!?!
    2010-12-10 09:25 AM
  18. Simon's Avatar
    You need to download tiny umbrella to find out what SHSH you have. You didnt isntall libusb on Vista did you?
    2010-12-10 12:40 PM
  19. herring14's Avatar
    Ok, i will download tiny umbrella. I tried to install libusb, but it didnt work and i assume that is what has messed up my laptop
    2010-12-10 03:34 PM
  20. Simon's Avatar
    ya libusb does not work well on vista. It can mess with your usb devices like keyboard and mouse if not installed correctly. I found that out the hard way too once and had to do a system restore to a point before I installed libusb.
    2010-12-10 05:06 PM
48 123
LINK TO POST COPIED TO CLIPBOARD