1. i.Annie's Avatar
    Its unclear at this time. There are some differences with this new update that needs some tweaking.
    2011-03-12 06:39 PM
  2. pshaktig's Avatar
    I have iphone 3GS. I was told while purchasing the device that it is factory unlocked and that all netwrok sims wud work on it but I could not validate his claims as I am a newbie. But the seller showed me different network sims working on it

    I had ios 3.x.x when i purchased it. I upgraded it to 4.3 and now my iphone doesnt detect the network(Airtel) for which sim was inserted. Before upgrade Airtel netwrok sim was working perfetcly fine. After upgrade when I insert some other network sim (vodafone) my iphone is just perfect.

    Please let me know how can I know whether my ipohne is factory unlocked though chances are minimal as it had cydia installed on it at the time of purchase.

    Second how can I make my iphone working on all the networks.

    some details
    iphone 3GS
    bootloader: 6.4
    baseband: 05.16.01
    ios: 4.3
    2011-03-12 07:26 PM
  3. kcsunil100's Avatar
    I have iphone 4 IOS 4.1 with BB 3.10.01, currently my iphone is locked and is already jailbroken for 4.1 with redsnow. I need to upgrade from 4.1 to 4.2.1. Could you please let me know the process of upgrading and also let me know which software I need to use (for 4.2.1 saw the replies that Greepoison should be used). As I need to upgrade to 4.2.1.

    PS: The reason for this is, previously I have synchronised all my applicatin from my pevious iphone 3gs 4.2.1 in Itunes, Now when I am not able to synchronise iphone 4 4.1 from the exisitng applications which already in my itunes.
    Can you please suggest me how I can proceed.

    2011-03-16 06:42 PM
  4. Simon's Avatar
    Dp you have 4.2.1 SHSH for the iPhone 4?
    2011-03-16 07:23 PM
  5. kcsunil100's Avatar
    Hi Car, yes, I have already saved 4.2.1 SHSH in Tinyumbrella. So now should I have use redsnow or greenpoison for upgrading without upgrading baseband?
    2011-03-16 08:40 PM
  6. Simon's Avatar
    Well you already have 3.10.01 baseband so no need to worry about updating your baseband if you are going to 4.2.1. Try closing tiny umbrella and not using it at all. Put the iPhone in DFU then shift restore to 4.2.1.
    2011-03-16 09:00 PM
  7. kcsunil100's Avatar
    Thanks for your quick reply, putting iphone in DFU mode means, does that mean without using any redsnow or greenpoison should I have to use itunes and press shift + restore and selected 4.2.1 restore.ipsw? if I misunderstood then pleas correct me
    2011-03-16 09:04 PM
  8. Simon's Avatar
    No need for redsnow and no need for greenpoison until after the restore. Just manually put it into DFU yourself (should be a black screen) then shift restore to the 4.2.1 regular firmware.
    2011-03-16 09:10 PM
  9. kcsunil100's Avatar
    Sorry for repeating my same question, what exactly mean by putting DFU manually? how to put into DFU manually?
    2011-03-16 09:14 PM
  10. Simon's Avatar
    2011-03-16 09:34 PM
  11. kcsunil100's Avatar
    I was trying to restore by connecting to itune then shift + restore and then selected 4.2.1 restore firmware, after few minutes I got an error message stating " iphone 4 could not be able too restore to 4.2.1" why igot this error message? and what is the solution for this?
    2011-03-16 09:35 PM
  12. Simon's Avatar
    2011-03-16 09:39 PM
  13. kcsunil100's Avatar
    Thank you Car, I will try to do the process exactly the steps meantioned in iClarified - iPhone - How to Put an iPhone Into DFU Mode after that I will try to do shift+restore and selecting 4.2.1 restore firmaware,.
    Thank you onceagain, once I done that process then will reply the message again.
    Thanks in advance
    2011-03-16 09:41 PM
  14. Simon's Avatar
    2011-03-16 09:52 PM
  15. kcsunil100's Avatar
    Hi Car, I have done exactly the same as descriped above (i.e.,putting DFU manually and then shift + restore and selected 4.2.1 firmware. After few minutes I got the same error message "Iphone could not be restored an unknown error occured (3014)". What i need to do now and what is the next process?
    2011-03-16 10:51 PM
  16. Simon's Avatar
    Maybe try it on another computer. Try using my tiny umbrella guide in my sig.
    2011-03-17 04:00 AM
  17. kcsunil100's Avatar
    Thank you, but what could be the reason for getting this error? because the same error got in my friend's computer as well.
    PS: I am using windows XP.
    Could you please let me know where can I find your tiny umbrella guide in my sig?
    2011-03-17 01:54 PM
  18. Simon's Avatar
    2011-03-17 04:05 PM
  19. Williams117's Avatar
    T*** we all appreciate what you do
    2011-03-23 03:57 PM
  20. kcsunil100's Avatar
    Hi, I have question on resetting to factory settings of my Iphone 4 IOS 4.2.1 with baseband 3.01.01. Currently my Iphone 4 has version 4.2.1 with baseband 3.10.01 and it is locked to service provider, also it is jailbroken. If I reset to factory setting or network settings, will my iphone 4 remains on same version like 4.2.1 and with same baseband 3.10.01? Kindly help me in this.
    Many Thanks
    2011-04-28 10:47 AM
87 ... 2345