1. htp182's Avatar
    I recently received an iPhone 4 with 4.0.2 FW and 1.59.00 baseband I successfully updated to 4.2.1 and preserved my baseband. I told Pwnagetool to activate the iPhone but it still says waiting for activation I inserted an ATT sim from a working iPhone 4 hoping to get past the prompt but it does not activate or find ATT for that matter also Cydia will not open to install ultrasnow. I have tried redsnow as well. Is there anyway to update the baseband to 2.10.04??? Any ideas>
    2010-12-24 04:45 AM
  2. iYeow's Avatar
    This is not a strange issue. Tiny umbrella should not be able to preserve your baseband for IOS 4.2.1. You were just in luck to get it past.
    Now run tiny umbrella and go to advance and uncheck the box : set hosts file to Cydia upon exit.
    Close it , reboot your pc.
    Run itunes and restore your iphone 4 to IOS 4.2.1 and let apple update the baseband. If your baseband doesn't match your firmware, you will not get signal and render your iphone 4 useless.
    2010-12-24 05:44 AM
  3. htp182's Avatar
    I need it unlocked though is there anyway to preserve and bring it down to 4.1 there are no SHSH saved for 4.1
    2010-12-24 11:04 PM
  4. iYeow's Avatar
    No, no tools is available yet and you cannot downgrade to 4.1 without shsh. The 4.1 baseband cannot be unlocked anyway.
    Wait for a new unlock, it is coming and is supposed to unlock BB 02 and 03
    2010-12-24 11:06 PM
  5. poncex's Avatar
    Well I did the same and my iphone works perfectly except for the camera, Im running 4.2.1 and BB 01.59.

    I'm having problems with an iphone 4, 4.0.1 and baseband 01.59.00 never jailbroken.
    The camera shutter is frozen, every time I try to use the camera it wont let me, not even other camera apps.
    Ive tried every single method I googled and still frozen, so I gave up and decided to restore it to 4.2.1 since this is my wife phone and doesn't care about unlock or jailbreak Ill gave it a try.
    Surprisingly the phone is running 4.2.1 and baseband 01.59.00 and functions perfectly but the stupid camera shutter still not working and thus the camera still unusable.

    Any thoughts on this?? How come the baseband wasn't updated??
    Any idea in how to fix the shutter problem??

    2011-01-03 04:59 AM
  6. theomer's Avatar
    Camera shutter problem sounds like the symptom of a bad camera - hardware wise. if you or one of your buddies knows what they are doing, you could swap the camera with another phone to see if that is the case... no guarantee though because it may also be the new baseband check in place doing something screwy.

    good job on the 4.2.1 + 1.59.00 though, about to go try that
    2011-01-03 05:47 AM
  7. theomer's Avatar
    so i just got done with 4.2.1 +1.59.00 custom restore, and the end result was what i wanted, but unbeknown to me, the baseband check will not allow the iphone 4 to get cell service with a non matching baseband.

    so now i look past and your camera problem and ponder how it is your phone is working. or does it in fact have cell reception?

    p.s. my camera works. but no cydia, safari, or cell service.
    2011-01-05 02:53 AM