1. steezysmurf's Avatar
    Need some help getting my phone unlock back...

    Short version:
    Ultrasn0w won't unlock my phone, I get error messages and hopefully someone knows how to fix them. iOS 4.1, BB 6.15, newer bootloader. Can't get out of recovery mode if I upgrade to 4.2.1.

    Detailed version:
    I have a 3G with the 6.15 iPad baseband installed on it. My phone froze while downloading a cydia app (specifically, the springboard reboot froze on me) and I was put in what I think is called a recovery mode loop (switching randomly between apple logo and itunes/plug in icons, unable to boot up). Now, I was on 4.2.1 iOS and from what I've read, you can't get out of recovery mode on this (correct me if I'm wrong?). So what I finally managed to do was get into iOS 4.1 (stock), but not after going back to 3.1.3 (stock) since it was the only iOS that would work and get me out of the recovery mode loop. Since redsn0w didn't want to jailbreak my phone on 3.1.3 I went to 4.1 where it worked, thankfully. Except now when I try to use ultrasn0w it won't unlock my phone, giving me the error messages I attached at the bottom of the screen.
    Attached Thumbnails Ultrasn0w error messages... phone won't unlock-photo.jpg  
    Last edited by steezysmurf; 2011-04-09 at 09:07 PM.
    2011-04-09 08:52 PM
  2. kaygee's Avatar
    Have you tried to turn phone off then restart cydia. I had a few errors downloading some things from cydia and I just restarted the phone and it worked.
    2011-04-10 02:33 AM
  3. steezysmurf's Avatar
    I figured it out actually. I typed in the wrong source code, but it took me a while to realize it :S. I would've assumed it wouldn't download at all if I entered the wrong code but no.
    2011-04-12 05:01 AM
  4. littlefoot's Avatar
    Make sure its


    Unfortunately, I don't know exactly what the proper fix is?!?! However, you might want to try reinstalling the "said" bad source...as it might have encountered an error during the recent updates, may just have a glitch or just be corrupt... Or if you can remove the source/repo in Cydia and reinstall... I have had similar problems in the past that I was able to fix/resolve through the simple reinstall or removal, install again method.
    2011-04-12 07:58 AM