1. MustangFTW's Avatar
    So i just bought an iphone 4 from a friend who was using it on tmobile, its IOS 4.0.1 BB 1.59.00 so when i got home today i popped my dads cut down sim into it and it didnt recognize it it would just show one bar and no carrier name (im on tmobile) i saved my blobs and upgraded to 4.2.1, couldnt get out of recovery so i downgraded back to 4.0.1 and there the same problem, i used greenpoison to jailbreak nad ultrasn0w 1.2.1 to unlock.


    ive tried airplane mode, reset network, restart, respring and restore nothin is working.

    could this be the sim card thats messed up? i dont have another micro sim handy.

    EDIT: i used limerain not greenpoison


    interesting thing happened, my dad put his sim in his old Vibrant and it didnt work either, activated a new sim and it worked, going to get it cut today and well see what happens.
    Last edited by MustangFTW; 2011-04-16 at 04:02 PM. Reason: Automerged Doublepost
    2011-04-16 04:02 PM
  2. nebo1ss's Avatar
    So i just bought an iphone 4 from a friend who was using it on tmobile, its IOS 4.0.1 BB 1.59.00 so when i got home today i popped my dads cut down sim into it and it didnt recognize it it would just show one bar and no carrier name (im on tmobile) i saved my blobs and upgraded to 4.2.1, couldnt get out of recovery so i downgraded back to 4.0.1 and there the same problem, i used greenpoison to jailbreak nad ultrasn0w 1.2.1 to unlock.


    ive tried airplane mode, reset network, restart, respring and restore nothin is working.

    could this be the sim card thats messed up? i dont have another micro sim handy.

    EDIT: i used limerain not greenpoison


    interesting thing happened, my dad put his sim in his old Vibrant and it didnt work either, activated a new sim and it worked, going to get it cut today and well see what happens.
    Sorry to tell you but you just locked your phone back to original carrier probably ATT. You should never upgrade an unlocked phone without knowing what you are doing and using custom firmware to avoid updating the baseband.

    The only baseband that can be unlocked on an ip4 is 1.59 when you updated the firmware you also updated the baseband. You can check this by going to settings-general-about but you are probably on 3.10.

    You might be lucky since you got an error when updating. In that case TU probably saved you by keeping your baseband.

    If you are still on 1.59 you need to go to cydia and install ultrasnow to unlock the phone.
    Last edited by nebo1ss; 2011-04-16 at 04:12 PM.
    2011-04-16 04:10 PM
  3. Stray's Avatar
    Ummm actually he used TinyUmbrella which preserves the baseband. It seems like he knows about shsh's.
    that was officially the scariest thing you have ever said str4y.
    Dude T.M.I
    2011-04-16 04:13 PM
  4. MustangFTW's Avatar
    lolno, i checked it dude its still on 1.59.00, this aint my first time around the block with iphones, ive already installed ultrasn0w, ive already locked one iphone 4 ths year so i made sure to not mess this one up

    thanks for suggestion though.
    2011-04-16 05:46 PM
  5. Stray's Avatar
    Told ya @nebo1ss
    that was officially the scariest thing you have ever said str4y.
    Dude T.M.I
    2011-04-16 05:47 PM
  6. jimrgraham's Avatar
    Hi - just trying to help a friend out who's iPhone 4 is on iOS 4.0.1 and BB 1.59.00. Was Jailbroken with Jailbreakme and have installed and deinstalled Ultrasnow v1.2.2 four times and still have the same issue. Sim works in another unlocked iPhone, so it has to be related to the unlock. Any ideas?

    Thank you in advance...

    Jim
    2011-04-29 07:57 PM
LINK TO POST COPIED TO CLIPBOARD