1. spoonful's Avatar
    Hi all. Got a strange unlocking problem here...

    I've got an iPhone 3GS running 4.3.3, bought refurbished and carrier free from the Apple Store. It was activated with my Orange SIM in store - the guy offered to as I had the SIM with me. I got it home and updated from 4.2.1 to 4.3.3 All was working good!

    It was playing up a few days ago - GPS wasn't getting a good fix in areas it used to before, so I restored it in iTunes. Note that it wasn't jailbroken or anything...completely stock.

    Unfortunately, after the restore, it wasn't recognising my SIM as valid...like the phone was locked to another network. This is the exact same SIM it was working with before the restore!

    I jailbroke with Redsn0w in order to apply the ultrasn0w patch, but then I found out that my baseband (05.16.02) isn't currently unlockable. Great. However, I would have though that it doesn't need unlocking since it was working fine with my SIM! Would it have been something to do with it being activated in store?

    I'm fairly familiar with jailbreaking as I did it on my 1st gen iPhone, but this has really stumped me. Any advice would be much appreciated. I'm going to take it back to the Apple Store on Monday if there's no solution. I don't want to change the baseband as that would mess up my chances of getting it sorted by Apple.

    Thanks in advance! Any help is much appreciated!
    2011-05-14 10:19 PM
  2. battlecrushr's Avatar
    It was probably unlocked w/ ultrasn0w
    Now ur gonna have to wait fir the new unlock.
    2011-05-14 10:26 PM
  3. spoonful's Avatar
    I bought it direct from the Apple Store though, carrier free. I doubt they would have unlocked it with ultrasn0w.

    I didn't jailbreak it until after it started rejecting my SIM.

    Thanks for the help!
    2011-05-14 10:30 PM
  4. battlecrushr's Avatar
    Oh yea good point
    Try rebooting ?
    2011-05-14 10:33 PM
  5. spoonful's Avatar
    Tried that.

    I'm baffled as to how it's rejecting the SIM even when it's completely stock and was working fine with that SIM before...

    Here's the iTunes message:
    Last edited by spoonful; 2011-05-14 at 10:42 PM.
    2011-05-14 10:38 PM
  6. battlecrushr's Avatar
    Hmm. Then hacktivate it. Jailbreak it with redsnow and See what happens
    2011-05-14 10:45 PM
  7. spoonful's Avatar
    I've just jailbroken it with Redsn0w...the carrier name isn't appearing in the status bar and I can't make calls.

    In the About bit in the settings, the carrier is 'unknown'.

    I don't even know what network it's now decided to lock itself to. On the advice of someone else, I tried putting it into DFU mode and restoring in iTunes with no SIM installed, but the same thing happens.

    (Also, I tested the SIM in my old 1st gen iPhone - works fine)


    Thanks again for the help.
    Last edited by spoonful; 2011-05-14 at 10:56 PM.
    2011-05-14 10:53 PM
  8. Simon's Avatar
    If you are getting that message in itunes then your iPhone is not factory unlocked. If it is supposed to be then you need to call Apple or the carrier you got it from and ask then what's up.
    2011-05-14 11:28 PM
  9. spoonful's Avatar
    Thanks. I'm going to take it into a store on Monday. It was sold to me as unlocked, and worked fine with my Orange SIM until I restored in it iTunes. At this point, it was completely stock too.


    Bloody genius bar reservation system seems to be down...great timing. Hopefully I'll be able to get an appointment.
    2011-05-14 11:34 PM
  10. spoonful's Avatar
    Well, in case anyone's interested, I took it back to the Apple Store and they ummed and erred over it for ages. Turned out to be a problem with activation of that phone's serial number their end, so they assigned a new serial to the phone and it all works fine now.
    2011-05-16 09:59 PM
  11. Simon's Avatar
    2011-05-16 10:44 PM
LINK TO POST COPIED TO CLIPBOARD