1. saimer's Avatar

    I'm a newbie on this so please forgive my ignorance. After reading multiple threads I'm really confusing and need help here.
    I just jailbroke my iphone 3G iOS 4.2.1 using redsn0w 0.9.6 rc9 also upgraded baseband to 06.15 for unlocking.
    I followed unlock instruction in tutorial section, ultrasn0w completed successfully. My carrier is Fido, and I tried with a Telus SIM card (from another working phone). It displayed no service on top left corner. I went to setting->carrier, it 'Rogers Wireless' - before changing SIM it's 'Fido'. In setting-> phone, new SIM card phone number shows correctly.

    Is there any special trick I missed? Is it safe to run ultrasn0w again?

    Thank you for your help!

    Btw, just downloaded Fuzzyband and checked my Bootloader version is 5.09.
    Last edited by saimer; 2011-11-19 at 09:28 PM.
    2011-11-19 09:15 PM
  2. i.Annie's Avatar
    Uninstall and reinstall ultrasn0w. Reboot twice. Then give it at least an hour to pick up signal. If it still hasn't picked up signal by that time, let me know.

    Edit: it once took an iPhone 3G I was working with 30 minutes to pick up signal after installing ultrasn0w, and another device took 15 minutes. Some just take more time.
    2011-11-20 02:25 AM
  3. saimer's Avatar
    Uninstall and reinstall ultrasn0w. Reboot twice. Then give it at least an hour to pick up signal. If it still hasn't picked up signal by that time, let me know.

    Edit: it once took an iPhone 3G I was working with 30 minutes to pick up signal after installing ultrasn0w, and another device took 15 minutes. Some just take more time.
    Hi Annie, I did what you said, first uninstalled ultrasn0w, rebooted. Then install again, when it finished, prompted message 'Could not activate cellular data network'. Does that mean I can't unlock this phone? Thanks.
    2011-11-20 11:54 PM
  4. i.Annie's Avatar
    It means your internet isn't working because your APN isn't set to the right one. Are you receiving signal bars or no?
    2011-11-21 12:22 AM
  5. saimer's Avatar
    I don't have any signal bar. What do you mean APN not set to right one? I still have wi-fi. But my phone plan doesn't have data plan and I remember I called Fido service to disable my data connection because I didn't want to accidentally connect through data and being charged unnecessary (it did happen a few times). Since then I've always using wi-fi for internet.
    2011-11-21 12:30 AM
  6. i.Annie's Avatar
    It doesn't matter what your APN is if your phone isn't unlocked. I was just telling you about what that error message means. The phone was unable to access an internet connection via the phone service bc you don't have one is all that the error means.

    If you don't have signal bars, does your carrier name show up at least.
    2011-11-21 12:37 AM
  7. saimer's Avatar
    Under settings->carrier, there's nothing. If I go into carrier, after searching, it returns 'Rogers Wireless' which is incorrect. Under settings->general->about, Carrier shows TELUS 9.0.
    2011-11-21 12:43 AM
  8. i.Annie's Avatar
    I meant in the status bar in the top left corner of the screen.
    2011-11-21 12:45 AM
  9. saimer's Avatar
    It says 'No Sverice' with wi-fi signal bar.
    Here's the screenshot. Sorry and thank you very much for your patience!
    Please help with iPhone 3G unlock-saimer.png
    2011-11-21 12:57 AM
  10. i.Annie's Avatar
    Hm yeah it's not unlocking for some reason as it should, especially with that 6.15.00 baseband installed. Sometimes I see this happen and it's just something that can't be helped.

    Edit: forget everything here. I'm going to write you new instructions.

    Ok, here's what you should try first. Download a stock 3.1.3 ipsw and a 3.1.2 as well.
    Download TinyUmbrella (google, first link)
    Download Redsn0w 0.9.4 (this version specifically)

    Open iTunes, hold shift, click restore.
    Select 3.1.3 ipsw
    Get error 1015
    Open TU, hit "exit recovery" (not fix recovery)
    Open Redsn0w
    Select 3.1.2 ipsw (not 3.1.3 this time)
    Select to install Cydia
    Access Cydia on Springboard after jb finishes
    Upgrade all essentials (in changes tab in Cydia)
    Install Ultrasn0w
    See if you pick up service after rebooting twice and waiting 15 minutes to an hour.

    I want to see if it will unlock on 3.1.3. Some users report that they can only have success on 3.1.3. If you really want iOS 4 on it though, we can deal with upgrading it back up to 4.2.1 later.
    Last edited by i.Annie; 2011-11-21 at 01:05 AM.
    2011-11-21 01:01 AM
  11. saimer's Avatar
    I'll try this. But before downgrading ... my understanding is that I'd lose all apps installed, right? I'll back everything up before starting if that's the case. Thanks again!
    2011-11-21 01:14 AM
  12. i.Annie's Avatar
    If you sync your apps to iTunes it shouldn't be a problem. Your jailbreak apps/tweaks will be lost though. Properly back them up with aptbackup in Cydia (not appbackup) if you want, but I would highly suggest you write them down bc sometimes aptbackup doesn't work right. For App Store apps, go to iTunes and right click your device, select "transfer purchases" then sync your device one more time. Then it should be fine. Though you'll lose game save data, since we're going to set it up as new rather than restore from a backup.

    Contacts: go to the info tab in iTunes and back them up to a third party.
    2011-11-21 01:18 AM
  13. saimer's Avatar
    Gotcha! I'm downloading now. Will let you know if it works ... probably be tomorrow. Again, thank you very much for your help!
    2011-11-21 01:25 AM
  14. i.Annie's Avatar
    Great, I look forward to seeing if you get it all worked out.
    2011-11-21 01:48 AM
  15. saimer's Avatar
    Hi Annie,

    Just a quick update ... I did downgrade and went through all steps, but still no service. This time ultrasn0w didn't give error after installation. So I tried again, removed and reinstalled ultrasn0w, didn't help, and both remove / re-install stuck at restarting springboard for very long, I had to hold power+home to turn off. After re-install, old Fido SIM gave no service too. I thought I completely deactivated my phone, but after 2nd remove / re-install, and signal was found. So I think it could be a SIM card / carrier problem.

    Now I'm on 3.1.3 bb 06.15. Still need help on unlock.

    Question, when unlocking (install ultrasn0w), does it matter which SIM card is in phone?

    2011-11-21 05:49 AM
  16. i.Annie's Avatar
    It shouldn't matter which SIM is in when you do the unlock. But personally I've always just had the SIM I wanted to use in, for example I used T-Mobile so I would leave that one in.

    Let's try a different approach... Do you happen to have a Mac? If not you might have to download a custom fw made by pwnagetool that has the iPad bb packaged. Sometimes people have to reflash the iPad bb back onto the phone. So...I suppose that's the only option left that I can think of.
    2011-11-21 06:03 AM
  17. saimer's Avatar
    Yes I do have a Mac, just not used to it yet. Is there a detailed instruction to follow on Mac?
    btw, I noticed after this downgrade, if I remove ultrasn0w, no SIM card would be recognized. I have to install ultrasn0w to have original Fido card work, and signal would drop sometimes, will come back up only after reboot.

    Oh, forgot to say, 3.1.3 is faster, but a few apps I used to use on iphone are incompatible with this version, so maybe eventually I'd like to upgrade to 4.
    Last edited by saimer; 2011-11-21 at 04:18 PM.
    2011-11-21 04:15 PM
  18. i.Annie's Avatar
    Yeah 3.1.3 is supposed to be best for an iPhone 3G. But you're right, a lot of apps aren't compatible unless you upgrade to iOS 4.

    I would highly suggest you use a Mac to create a custom 4.2.1 fw, and build the iPad baseband into it. I can find a link for a guide for you. I'll be right back.

    Update iPhone 3GS / 3G Baseband to 06.15.00 with PwnageTool 4.1.3 for iOS 4.2.1 Unlock [Guide] | Redmond Pie

    Here's a good one. The picture shows 4.1 but the instructions say you can use either 4.1 or 4.2.1, so use 4.2.1 bc I said so.
    2011-11-21 04:41 PM
  19. saimer's Avatar
    I'll try when I get home tonight.
    But here's what I found out at work ... I asked for a few SIM cards from different carriers in Canada, Rogers card worked right away, since Rogers and Fido are the same operator (but without unlocking, the one shouldn't work either), no dice on Telus cards, still no service. A Videotron card (a QC company) was recognized as 'Partner'. Bell SIM is the same as Telus getting no service. So I won't put high expectation on next attempt. It might be some trick done by Canadian service providers.
    2011-11-21 10:11 PM
  20. saimer's Avatar
    Please ... help again!
    I know unlock probably won't work but tried with above mentioned method to upgrade (or go back) to 4.2.1 because I really want some apps back. But I got error 1015 in itune when restoring custom ipsw. Is there a way to get me back to 4.2.1 with or without unlocking?
    2011-11-22 05:56 AM
29 12