1. GrandMstrBud's Avatar
    I kind of thought so because I remember seeing something about it.
    2011-12-01 02:25 AM
  2. i.Annie's Avatar
    Well I did some research. There's apparently a Cydia package that fixes it as well. I'm assuming the package does what the manual method does. If you don't mind giving that method a whirl and letting us know, that'd be awesome. But I totally understand if you don't want to undo what you've already accomplished.
    2011-12-01 02:27 AM
  3. GrandMstrBud's Avatar
    I have seen a repo that has the fix ultrasn0w files but when I went to install them cydia would not let me. This is the site I originally found out about it. This one should be approved for posting.

    http://www dot iphoneinformant.com/2011/11/unlock-iphone-3gs-iphone-4-on-ios-5-0-1-with-ultrasn0w-fixer/
    2011-12-01 03:16 AM
  4. i.Annie's Avatar
    You tried with ultrasn0w uninstalled?
    2011-12-01 03:55 AM
  5. GrandMstrBud's Avatar
    Yep, cydia wouldn't even let me install it. Something about not compatible with the current iOS
    2011-12-01 06:06 AM
  6. i.Annie's Avatar
    Bummer. I'm probably going to go dig around for some feedback on this package, it'd be so much easier if it worked than teaching people how to do it manually.

    UNLOCK 5.0.1 iPHONE 3GS with ULTRASN0W 1.2.4 + FIX ULTRASN0W

    One person said it worked. Don't know how reliable this is lol.
    Last edited by i.Annie; 2011-12-01 at 06:17 AM.
    2011-12-01 06:12 AM
  7. GrandMstrBud's Avatar
    Well that repo doesn't even work, I can add it but there's nothing ther
    2011-12-01 06:21 AM
  8. i.Annie's Avatar
    Dang. I guess it's the manual way or no way.
    2011-12-01 06:24 AM
  9. GrandMstrBud's Avatar
    Okay I removed it the manual way then uninstalled ultrasn0w and then installed it again. Then I installed the fix for the 3GS from the following repo, iphone4g-pro's Repository - MyRepoSpace.com, and rebooted and now I'm stuck in a boot loop. So looks like I'll have to restore and use the manual method.
    2011-12-01 06:46 AM
  10. Sambran007's Avatar
    I did this and it worked for me. You need to change your permissions on your iPhone using ifile
    2011-12-01 12:35 PM
  11. jhbalaji's Avatar
    Sure! May i know to what on i need to change permission on iphone?

    See this Unlock iPhone 4 3GS 5.0.1 With Ultrasn0w
    Last edited by jhbalaji; 2011-12-01 at 03:27 PM.
    2011-12-01 03:09 PM
  12. Sambran007's Avatar
    Download 3gs_5.0.1.rar for free on Filesonic.com (Download 3gs_5.0.1.rar for free on Filesonic.com)

    1. iPhone

    2. Jailbreak iPhone on 5.0.1

    3. from cydia install iFile (do a search)

    4. iFunBox ( http://dl.i-funbox.com/ifunbox_en.zip )

    5. CommCentreClassic file (LOCATED IN THE 3gs_5.0.1.rar)

    Step by Step:



    INSTALL iFile FROM CYDIA.

    Connect iphone to PC then open ifunbox go to :

    raw file system ---> /System/Library/Frameworks/CoreTelephony.framework/Support/

    delete CommCentreClassic and copy the CommCentreClassic ( that comes with the 3gs_5.0.1.rar )

    close ifunbox.

    Open iFile and go to : System/Library/Frameworks/CoreTelephony.framework/Support/commcentreclassic

    click the Blue arrow next to the file name, go to access permissions, you'll get user group and global (World) and :

    set like this:
    User: check writing, execution and reading
    Group: check writing, reading and execution
    Global (world): mark reading and execution

    click done at the top

    go to cydia install ultrasn0w, reboot automatically from cydia,

    insert the SIM card in your iphone and should work
    2011-12-01 05:43 PM
  13. General Mayhem's Avatar
    Hi, I am trying to unlock two iPhone 3GS that I bought from redtag.com - I have tried to jailbreak only one unit and have been successful by using sn0wbreeze v2.8v11 and bb is now at 06.15.00 and FW 5.0.1 - I get No Service and have not been able to unlock. I tried the steps above for the iFile and so forth... Still no luck.

    Have 3GS 5.0.1 at 06.15.00 New Boot get No Service using T-mobile

    any advice?
    2011-12-01 08:58 PM
  14. Sambran007's Avatar
    Did you uninstall Ultrasn0w before you tried the fix? Also I have encountered many who just add the source, and they forget to actually install Ultrasn0w. Please do not take offense to my simple solutions, I am a simple minded person and I have found that simple solutions are the easiest to eliminate first. Also did you make sure 3G was off before you did the fix? Let me know and we can work from there.

    Sam
    2011-12-01 09:10 PM
  15. General Mayhem's Avatar
    Sam, I just read your reply, I uninstalled Ultrasn0w - took my sim out. I then made sure that 3G is off and installed Ultrasn0w, inserted my Tmobile sim after reboot and it WORKS!!!! Thank You - I have 5 bars and was able to get texts and make calls - THANK U
    2011-12-01 09:39 PM
  16. jhbalaji's Avatar
    It wasted MY TIME a lot! DIDN'T WORKED... NO SIM OR SEARCHING

    Does the ultrasnow requrie offical sim card to activate??
    If yes any way to bypass
    Last edited by jhbalaji; 2011-12-01 at 11:37 PM.
    2011-12-01 11:21 PM
  17. i.Annie's Avatar
    Please try to be a little more respectful. This person took the time to find and post a solution for us. It worked for the above user so it must be a working solution.

    Ultrasn0w is an unlock tool in Cydia, it has nothing to do with activating the phone. Of course if you don't have any official SIM, hacktivating with a jailbreak tool should do the job.
    2011-12-02 12:07 AM
  18. Sambran007's Avatar
    Sorry it didn't work for you, but you gotta understand this is a process (hence the reason there are so many solutions out there). If you wanna solve your problem you gotta give me some more info. Did you uninstall ultrasn0w? 3G off? Do you have a working sim? And I can attest that this solution does work, how do you think I am writing this.
    Last edited by Sambran007; 2011-12-02 at 01:18 AM.
    2011-12-02 01:15 AM
  19. General Mayhem's Avatar
    ok I was able to jailbreak my 2nd 3gs iphone in less than 45min. Went from 4.3.5 / 5.16.02 to 5.0.1 / 6.15.00 using sn0wbreeze v2.8v11 and following the steps Sambran007 lists in #52 above. rebooted using ibooty - inserted Tmobile sim and success again! My kids will be happy this holiday with their new phones. Thanks to ALL THE POSTERS AND MODS
    2011-12-02 06:15 AM
  20. jhbalaji's Avatar
    Finally this worked!
    *Link removed - steps included piracy repo*

    Thanks all!
    Last edited by i.Annie; 2011-12-03 at 09:02 PM.
    2011-12-02 08:07 PM
83 12345
LINK TO POST COPIED TO CLIPBOARD