1. piedrafina's Avatar
    i am trying to jailbreak and unlock a 3gs and i keep getting weird errors. i am hoping someone can help me.

    it had 4.1 originally, so i upgraded to 5.0.1 and jailbroke it with redsn0w. after entering dfu mode, when i select both install cydia and ipad bb, redsn0w spontaneously exits. so i tried clicking only the option to install cydia. when i do that, i can jailbreak it. it was unlocked on 4.1, so the baseband is already set to 6.15.00. so, i went to cydia, added ultrasn0w source and installed it. however, i get the following error:

    some index files failed to download. they have been ignored or old ones used instead.\

    i have tried setting it up as a new phone and restored from the backup. neither made a difference.

    as it stands, the phone gets no service and is completely useless.

    editing to add that i tried installing ultrasn0w again after posting the above and it ran with no error. however, when i put the simple mobile sim card in, it still says searching.

    also, when i click on the ultrasn0w source on the manage sources page, nothing shows up. shouldn't it show up there?

    editing again to add that i was able to add ultrasn0w by adding a repo from sinful iphone. however, it still shows searching and then goes to no service whenever i put a sim card in.
    Last edited by piedrafina; 2012-02-01 at 06:16 AM.
    2012-02-01 04:41 AM
  2. piedrafina's Avatar
    can someone please help me? i really need to get service on this phone.
    2012-02-01 06:43 PM
  3. i.Annie's Avatar
    Try restoring to custom 5.0.1. You need a custom fw if you've got the iPad bb installed.
    2012-02-01 07:26 PM
  4. piedrafina's Avatar
    hmm... i am wondering how i got our other 3gs unlocked then. i restored to factory fw in itunes, then jailbroke with redsn0w and locked with ultrasn0w. it was previously jailbroken and unlocked on 4.2, so it had the ipad bb. even so, had no problem at all updating to stock fw. i tried the same process with this phone and it just isn't working.

    i am off to cook up a custom fw in sn0wbreeze and see if that works.
    Last edited by piedrafina; 2012-02-01 at 10:37 PM.
    2012-02-01 10:33 PM
  5. piedrafina's Avatar
    ok, i did the custom fw and viola! thanks! however, i'm stuck now with the other phone. i'm posting another thread about it.
    2012-02-03 02:09 AM
  6. i.Annie's Avatar
    2012-02-03 03:38 AM