1. yakabod's Avatar
    iPhone 3GS
    Version 5.0
    Baseband 06.15.00
    Model MB715LL


    Was used for AT&T now want to use for Tmobile. What would be the proper procedure to successfully jailbreak and unlock this phone?


    Thank you!!!!!!!
    2012-04-13 05:20 AM
  2. 2k1's Avatar
    Jailbreak first then use ultrasnow to unlock
    2012-04-13 05:25 AM
  3. yakabod's Avatar
    Ok, so I will jailbreak the firmware 5.0 and then use ultrasn0w? I don't need a custom ipsw?
    2012-04-13 05:30 AM
  4. 2k1's Avatar
    If you stay on 5.0 no but whenever ya update ya firmware in the future yea you will need to preserve that baseband.
    2012-04-13 05:32 AM
  5. yakabod's Avatar
    On the ultrasn0w page in the devteam section and it says don't use redsn0w when using ultrasn0w? This is getting me confused.

    I downloaded the latest redsnow. I will jailbreak the 3GS right now. and where can i download ultrasn0w? I can't find the link. Thanks.
    2012-04-13 05:52 AM
  6. celeron's Avatar
    You download ultrasnow after jailbreaking on cydia
    If my post was good, click the button in my post

    New to jailbreaking? Have a look at my Redsn0w Guide
    2012-04-13 06:08 AM
  7. yakabod's Avatar
    This is wack! I JB it and it said it's currently tethered! How can i make this untethered instead?!
    2012-04-13 06:20 AM
  8. celeron's Avatar
    You cant. 5.0 is tethered
    If my post was good, click the button in my post

    New to jailbreaking? Have a look at my Redsn0w Guide
    2012-04-13 06:25 AM
  9. yakabod's Avatar
    What firmware can i update it too to make it untethered? 5.0.1? or should i just update to 5.1?
    2012-04-13 06:29 AM
  10. celeron's Avatar
    5.0.1 is untethered but you can only update to that firmware if you have the shsh blobs saved for it
    If my post was good, click the button in my post

    New to jailbreaking? Have a look at my Redsn0w Guide
    2012-04-13 06:31 AM
  11. yakabod's Avatar
    hmm... i just loaded cydia and the is says SHSH: iOS 4.1, 4.2.1r1, 4.3 and 5.0.1. Does that mean im good to upgrade? whats the next step?
    2012-04-13 06:44 AM
  12. celeron's Avatar
    You can downgrade to 4.1 or update to 5.0.1.

    To go to 5.0.1 Download tinyumbrella. And go to the advanced tab and make sure every option is checked except for the iphone 4 baseband option. Start tss server and update thru itunes.

    Remember you have to make a custom firmware to preserve baseband, di that with sn0wbreeze or redsn0w.
    If my post was good, click the button in my post

    New to jailbreaking? Have a look at my Redsn0w Guide
    2012-04-13 06:53 AM
  13. rl421403's Avatar
    if you were on AT&T and have iPhone 3GS then it must be a old phone.
    You can ask AT&T to unlock you phone. They are unlocking contract free iPhones.
    If you qualify then you don't need to use ultrash0w anymore. just need to jailbreak.

    Hereís how to use AT&Tís online chat to unlock your iPhone
    2012-04-13 08:38 AM
  14. 2k1's Avatar
    If you have the old bootrom for the 3GS you can be untethered on any firmware.
    2012-04-13 01:32 PM
  15. tre999's Avatar
    you must have already done summin as you state you have BB 06.15.00 which is ipad bb and cant be changed at the mo,but of course is unlockable..
    2012-04-14 11:31 PM
  16. planktonika's Avatar
    He'll always have to have it jailbroken so the baseband will work, no?
    2012-04-15 02:52 AM
LINK TO POST COPIED TO CLIPBOARD